Third Age - Total War is a total conversion for 'Medieval II: Total War - Kingdoms Expansion' that brings you into the world of Middle-earth.

Report abuse Third Age - Total War 3.0 Part 2of2
Filename
TATW_3.0_Part2of2.exe
Type
Full Version
Uploader
TW_King_Kong
Date
Dec 12th, 2011
Size
2,039.49mb (2,138,558,080 bytes)
Downloads
874,670 (29 today)
Embed Button
Mirrors
Download now
Description

3.0 (Part2) Download. Click on read more to see the full changelog and notes.


Main features:
- 25 new and unique custom settlements
- Several new units
- New High Elves
- New battlefield textures
- New skies, water and weather
- New campaign map textures & features
- More settlements
- New gameplay elements (The One Ring, Palantirs, Autonomous regions, Invasions, more culture-specific gameplay, etc..)
- New battle AI
- Slightly improved campaign AI
- New music and voices
- new characters
- added buildings, changed techtrees
- balance changes
- and more...

Preview Image
Third Age - Total War 3.0 Part 2of2
Post comment Comments  (50 - 100 of 192)
havoc201
havoc201 Dec 18 2011, 1:33pm says:

Thank you, thank you oh my precious

+2 votes     reply to comment
STOKK-E
STOKK-E Dec 18 2011, 2:49pm says:

download does not work

+2 votes     reply to comment
jellekr
jellekr Dec 18 2011, 4:20pm says:

why not?

+2 votes     reply to comment
Stuart207
Stuart207 Dec 19 2011, 12:41pm says:

it finally worked had to download it five times but it is amazing!!!!!

+2 votes     reply to comment
Guest
Guest Dec 17 2012, 3:43pm replied:

This comment is currently awaiting admin approval, join now to view.

jellekr
jellekr Dec 19 2011, 5:16pm says:

from Gamefront link?

+2 votes     reply to comment
jellekr
jellekr Dec 19 2011, 5:23pm says:

stil can't get error about the headliners: ERR_RESPONSE_HEADERS_MULTIPLE_CONTENT_DISPOSITION

+1 vote     reply to comment
SovereignReaper
SovereignReaper Dec 19 2011, 11:55pm says:

I have the recent version of this mod installed can I delete it or does it still need to stay?
*NEVERMIND PLEASE DISREGARD THIS QUESTION*

0 votes     reply to comment
Legolose
Legolose Dec 20 2011, 9:06am says:

@ YouKnowWho? - lol glad you found your anwser because I wa about to light you up ;)

+1 vote     reply to comment
jellekr
jellekr Dec 20 2011, 9:21am says:

OMG it is finally working downloading it rigth now!!!!! :D

+1 vote     reply to comment
Goobaman
Goobaman Dec 21 2011, 5:46am says:

how do you put it into the game or is it like the darthmod mod it just creats its own shortcut to the game? p.s it took me 25 mins to download :)

+2 votes     reply to comment
Legolose
Legolose Dec 21 2011, 8:18am says:

It has its own installer and it will put a "ring" on your desktop just hit that and your in the game ;)

+2 votes     reply to comment
thepat-man
thepat-man Dec 22 2011, 12:26am says:

i wish moddb would host, gamefront says it's gonna take 12 hours.

edit: awwww yea it let me dl from moddb only 1 hour.

+1 vote     reply to comment
Babyjesas
Babyjesas Dec 25 2011, 1:37pm replied:

how do you dl it from moddb??

+1 vote     reply to comment
Yiio
Yiio Dec 22 2011, 9:31am says:

part 1 took 4 hours for me so maybe 5-6 hours for this:)

+2 votes     reply to comment
Legolose
Legolose Dec 22 2011, 10:46am says:

Wow, strange I got both parts in about 1 hour ,,

+1 vote     reply to comment
Guest
Guest Nov 18 2012, 10:56am replied:

This comment is currently awaiting admin approval, join now to view.

jellekr
jellekr Dec 25 2011, 7:43pm says:

omg how hard can it be to get the rebuild Osgiliath i got the Huge city in E.O and Citadel in W.O

+3 votes     reply to comment
Legolose
Legolose Dec 26 2011, 9:23am says:

The revised updated Frequently Asked Questions is now complete Twcenter.net

+4 votes     reply to comment
Mrbenbeal
Mrbenbeal Dec 28 2011, 12:13am says:

i downloaded the first part ok but when i finish downloading the second one, when i click run, it brings me to this black screen with a little blip flashing at the top of it and doesn't do anything how do i go about fixing this should I redownload it?

+2 votes     reply to comment
Legolose
Legolose Dec 28 2011, 10:19am says:

Have you tryed everything here first Twcenter.net if so then it should work, also maybe try redownloading it again and see if you have the same problem....

~~~~~Hope This Helps~~~~~

+4 votes     reply to comment
Ferran12
Ferran12 Dec 28 2011, 8:46pm says:

its telling me there are invalid files in the second part...anyone see the same issue

+2 votes     reply to comment
Legolose
Legolose Dec 29 2011, 10:35am says:

If you get the error "Invalid Data" then you will have to wipe out your old download and redownload it, sorry but it happens some times...

~~~~~Hope This Helps~~~~~

+3 votes     reply to comment
Guest
Guest Apr 19 2013, 8:53am replied:

This comment is currently awaiting admin approval, join now to view.

blackhorse312
blackhorse312 Dec 31 2011, 4:31am says:

The speech seems not too fast,but i can play it soon!thanks!

+2 votes     reply to comment
Legolose
Legolose Dec 31 2011, 11:46am says:

Speech ???? What you mean???

+2 votes     reply to comment
iwannadownlode
iwannadownlode Jan 1 2012, 11:43pm says:

i must admit im mildly confused... the first part i downloaded at over 1mb/s, part 2 im downloading at 0.1mb/s... noooooo now i have to wait longer to play it!

+2 votes     reply to comment
Legolose
Legolose Jan 3 2012, 2:40pm says:

lol it really doesnt take that long to download, trust me ;)

It all depends your internet and how many people are downloading at the same time on the same server so...

+2 votes     reply to comment
Argaleb
Argaleb Jan 4 2012, 4:26pm says:

It has allowed me to Download both parts but only intall part one :(

+2 votes     reply to comment
dotred108
dotred108 Dec 16 2012, 11:33am replied:

exactly

+1 vote     reply to comment
Legolose
Legolose Jan 5 2012, 3:31pm says:

Then re-download there must be some problem because I didnt have a problem installing anything, just re-download part 2 and see if that works, just make sure you wipe out your old download first.

+2 votes     reply to comment
AhzekAhriman
AhzekAhriman Jan 19 2012, 1:34am replied:

my both parts took only 30 mins both :D

+2 votes     reply to comment
jediknight12
jediknight12 Jan 23 2012, 8:20pm says:

i dnt get this at all, i finally finished downloading everything and i played it this morning i was recruiting new troops and stuff the i saved it and got off now im trying to get back on the game and its stuck on the loading thing its pitch black with the little lord of the ring thing goin around n circles its been doing so for at least 10 min WHAT THE CRAP DO I DO, WHY ISNT IT WORKING!!(also i didnt even get the chance to end my turn for the first time on the game. PLEASE HELP ME!!!

+2 votes     reply to comment
Legolose
Legolose Jan 29 2012, 10:44pm says:

Your cpu must have updated or something was loaded on your cpu to cause this so therefore there is nothing I can suggest to help you because this is not a problem I have seen before, try uninstall it and reinstall and see if it works after that.

+2 votes     reply to comment
casu
casu Feb 21 2012, 3:33pm says:

it took me about in total both bits about 4h but i have not done patching bit yet or installed just downloaded

+2 votes     reply to comment
The4nimal
The4nimal Mar 11 2012, 8:47am says:

just a suggestion, future patch 3.2 could fix more problems:

- low range of movement of dwarves on world map
- less options to earn money
- sometimes bad performane-balance on world map (despite good pc)
- maybe more units to recruit
- cannot dismiss agents

+2 votes     reply to comment
arkan36
arkan36 Mar 23 2012, 1:23am says:

everytime i have a battle in game it stops working :(

+3 votes     reply to comment
legonemo
legonemo Mar 27 2012, 12:04pm replied:

I have the exact same problem and ive tried reinstalling it 2 times :( help plox

+2 votes     reply to comment
dotred108
dotred108 Dec 16 2012, 11:34am replied:

can you tell me how to install part 2

+1 vote     reply to comment
Belgarath19
Belgarath19 Apr 19 2012, 8:19am says:

Legolose or anyone help when i try to strat a battle the game jst crashes

+2 votes     reply to comment
Hapless
Hapless Apr 22 2012, 9:21pm says:

You could make many more patches by the time the download finishes. lmfao

+2 votes     reply to comment
Slim_ShadyxDOCx
Slim_ShadyxDOCx May 9 2012, 10:44pm says:

I downloaded Total war kingdoms, via SteamTM and when I downloaded the mod, it said cannot find kingdoms.exe. What should I do!?

+2 votes     reply to comment
Slim_ShadyxDOCx
Slim_ShadyxDOCx May 9 2012, 10:51pm replied:

fixed that but now it comes up with "application load error"
WHAT NOW!!!???

+2 votes     reply to comment
nathan1x
nathan1x May 20 2012, 4:06pm says:

hey, this is probably a problem with my computer but i hope someone here will be able to help me, i managed to install the first part of the mod, but my computer doesn't seem to want to even run the other part, my downloads folder has been open for about 2 hours being unresponsive (even though it doesn't say so) but at the same time trying to run it. I had a similar problem with part one, but i used 'run' and that seemed to make it work, i tried the same with part 2 but it hasn't worked.

+2 votes     reply to comment
DMUC
DMUC May 27 2012, 11:58am says:

Mine was unresponsive for about a min and then it just started working.

+2 votes     reply to comment
serspencerpylatuk
serspencerpylatuk Jun 13 2012, 5:21pm says:

I keep getting an "Invalid data" error, and everytime I redownload, the file that is invalid is different... Help!

+2 votes     reply to comment
Fenris58
Fenris58 Jul 9 2012, 10:01pm says:

Look at the top of the comments. Legolose has already said the fix.

+2 votes     reply to comment
rebelbrigade
rebelbrigade Jul 14 2012, 1:22pm says:

gamefront doesnt work for me idk why but everytime i try to download a mod part my PC says could not acess site. is there another place where i can download part 2/2 and patch 2.1,2.2? and is there a reason why my PC wont let me acess gamefront

+2 votes     reply to comment
GeneralRAM
GeneralRAM Jul 25 2012, 7:04pm says:

I have a problem: Whenever I'm going to start the deployment for a battle, the game closes and a message appears. It says: "Medieval 2: Total War has found an unspecified problem and will now exit"... can someone help?

+3 votes     reply to comment
atsikenaytu
atsikenaytu Jul 29 2013, 5:29pm replied:

please help ı have got the same problem

+1 vote     reply to comment
Post a Comment
click to sign in

You are not logged in, your comment will be anonymous unless you join the community today (totally free - or sign in with your social account on the right) which we encourage all contributors to do.

2000 characters limit; HTML formatting and smileys are not supported - text only

Icon
Medieval II: Total War: Kingdoms Icon
Platform
Windows
Developed By
TW_King_Kong
Contact
Send Message
Official Page
Twcenter.net
Release Date
Released Apr 27, 2009
Mod Watch
Track this mod
Download
Browse
Downloads
Add Download
Members only
Report Abuse
Report download
MD5 Hash
f78f4eb66cf66906ca100b6e4e0152b0
Related Mods
Third Age - Total War (Medieval II: Total War: Kingdoms)
Third Age - Total War Medieval II: Total War: Kingdoms - Single & Multiplayer Real Time Strategy
Related Games
Medieval II: Total War: Kingdoms
Medieval II: Total War: Kingdoms Single & Multiplayer Real Time Strategy