Same mod, different name, The Galactic Empire, the Rebel Alliance, the Black Sun Pirates, and the Droid Empire, fight for control of the galaxy.

Forum Thread
by member
  Posts  
Bugs (Mods : Super Star Wars: Rise of the Droid Empire : Forum : Bugs for Super Star Wars : Bugs) Post Reply
Thread Options 1 2 3
Apr 13 2013, 2:53am Anchor

1. This was a mistake when I changed to a different Munifcent model. I didn't changed the model name in the xml. It works now.

2. Done on purpose so they have extra satellites to choose from.

3. Was intended to be single, don't know why Wookiees and Pirates won't fire. They have been removed.

4. Some disappear to make room for other units.

5. SSDs have been fixed, Lucrehulks should have that many, Ewoks are still in the mod, but have 3 pop cap, cost 4000 to build, and only one squad can be built.

6.Working on it.

Apr 13 2013, 3:24pm Anchor

If i may make a suggestion about skirmish you could just put all the upgrades and hero's on the research station only to make room for more units or if that doesn't make enough space perhaps make a fighter factory ship for advanced fighters. such as an arc hammer that manufactures fighters. i believe i saw that in a different mod.

 The mod was UEAW v4.0

Bugs:
the planet despayre land map border in gc is showing. if you send units there it causes an exception error.
droid empire shield generators behave as normal buildings which results in them being placed in somewhat useless building spots.
hk-80's have no death clone.
If b1 battledroids were included in this version i can't find them on geonosis or hypori. same with b2's unless they were replaced by the b4's.
If the Empire is supposed to be able to build trandosian units in gc i can't find where to build them. if its trandosa then i can't build them.
Dark trooper phase zero's won't land after using there jump pack ability
MDU deploy prefab building pad ability doesn't do anything.
in gc there are several planets that you cannot move your base or troops around on planet. i.e. bothawie
the dauntless class cruiser has no tractor beam hardpoint so it can't use its tractor beam. theres also a few colorless hardpoints on the model.
anti air turrets can target darth vader in land battles.
T-4B tanks can't fire missles
Trandosha map won't load.

Edited by: Darth_Weasel

Apr 19 2013, 1:26am Anchor

When i play most star wars mods i get bugs when pop cap goes over 1000-1200. Cant move some units on Galaxy map. When i try they clone them selves and becomes ghost units.
Anyone else have similar problems?
What causes these bugs. And how to fix them.

Apr 19 2013, 6:19pm Anchor

Bugs:
The planetary shield generator has no apparent effect. 
Idk if this was intended or not but the rebels have no turbolaser tower defenses.

Question:
is there a fix for mandalore yet?

Edited by: Darth_Weasel

Apr 19 2013, 7:42pm Anchor

1. You mean the shutter shield? It does, it blocks orbital bombardment, bombing runs, and the enemy from landing troops in a large radius around it. It doesn't work like a normal shield generator.

2. It's fixed in the next version.

3. What fix for Mandalore? I've never had problems with it.

Apr 20 2013, 12:31am Anchor

i get an exception error everytime I attack mandalore. (auto resolve or player fought) in GC.

Edited by: Darth_Weasel

Apr 20 2013, 12:45am Anchor

I haven't gotten an exception ever.

Apr 20 2013, 5:16pm Anchor

did i perhaps install incorrectly? ik i've seen other people with problems with mandalore but with an AI rebel player. maybe i'll go try it with an empire player.

also when the emperor and boba fett dies in gc they disappear forever.

Apr 22 2013, 6:15pm Anchor

Hello,
I downloaded this super star wars mod and i did all the steam mod stuff, and everything went well.
When i started SWFOC, it said this "xml parse error -file./data/xml/guidialogs.xml: file has syntax errors, see log file

I have no clue how to fix this :/

Apr 22 2013, 7:32pm Anchor

I have no clue either, this is the first time I've heard of that.

Apr 24 2013, 6:47pm Anchor

Bugs:
the empire's plex soldiers glitch when put in a bunker. they become singular units permanently. 
plex soldiers trip mine ability won't work.
mdu place prefab building pad doesn't work or have an icon.

Apr 25 2013, 2:51am Anchor

I forgot to add create team type for Plex Stormtroopers. If you want to add it, look for the file UNITS_LAND_EMPIRE_NEW_STORMTROOPERS.xml and look
for Imperial_Plex_Squad, then add this  

code:
<Create_Team_Type> Plex_Stormtrooper_Team</Create_Team_Type>

I working on the other two.

For the previous ones I haven't answered.
1. I'm not sure what you mean about Despayre.
2. The Droid shield genereator is one that I don't how to fix.
3. HK-80s are meant to faded after death, but they are not doing their job.
4. B1s and B2s are not in the mod.
5. Trandoshans require a Barracks and Trandosha. They may not be visible on the build bar if you have too many units.
6. This a glitch with Phase Zeros that I can't fix, but they can still move. Click on the troopers and then click on the stop button and they will land.
7. If you are referring to the Map preview that allows units and structures to be move in GC, I can't fix this, even though I've made the map previews correctly.
8. The Dauntless no longer has a Tractor beam and I don't what you mean by colorless hardpoints.
9. AA Turrets are meant to target Vader and all infantry and vehicles.
10. Go to Planet.xml and change the land Trandosha map name to Land_Planet_Trandosha.ted

May 3 2013, 3:28am Anchor

Thanks for the plex trooper fix!

when i say Despayre (i probablly spelled it wrong sorry) i mean the planet by the maw and kessel that was added.
what i mean by the dauntless having colorless hardpoints i mean the peices that get blown off when a hardpoint is destroyed appear white.


BUG:
whenever i auto resolve a land battle at mandalore with the empire i get an exception error.

May 3 2013, 5:08am Anchor

1. That is the planet.

2. I think I will replace the Dauntless model with a better version, I didn't really like the current one in the first place.

3. It might be better not to auto-resolve battles on Mandalore. There are some mods who usually have this problem and that it their suggestion. A few just remove the auto-resolve from the game, which I won't do. Since I rarely auto resolve battles, this may be why I haven't gotten a exception.

May 10 2013, 8:30am Anchor

Hello Admiral-Ace,
i downloaded your Mod and played GC. It is awesome! But unfortunately i run into a serious bug... I can't select my units anymore! No matter how I get into battle, even with new units, I can't select any of them. Now I'm unable to continue my GC. I've searched for a fix, but I just found these sites:
(http) moddb.com/mods/stargate-empire-at-war/forum/thread/unable-to-select-units
(http) gutr.swrebellion.com/forums/index.php?topic=2816.0
(http) petroglyphgames.com/forums/index.php?/topic/13014-unable-to-select-units-after-a-certain-time/
I'm having the same problem as the persons in these links.Do you have any idea how to fix this? Because I wasted so much time on this savegame, and now I can't continue playing... :-(
Many thanks in advance
SebbiUltimate

Edited by: SebbiUltimate

May 22 2013, 12:47pm Anchor

Edited by: cramxim

May 26 2013, 9:26pm Anchor

so im having trouble getting the droid empires space station past lvl 2. and i saw the post about changing the files, but it wont let me save them. says it doesnt have the right path, but i tried fixing that and that wont work either. idk what to do.

May 26 2013, 11:32pm Anchor

Pieboybom: Is your computer OS Vista or 7? If so, you will need to modify the permissions of your EAW FOC folder in order for you to be able to save over the original file.

May 27 2013, 3:04pm Anchor

Its Vista. where would i go to modify the permissions? normally it pops up asking, but this time nothing.

Never mind, i got it. thanks for the help. :) btw, love the mod.

Edited by: Pieboybom

Jul 11 2013, 8:14pm Anchor

Playing as the Empire. The AI has apparently produced Galen Marek, which I gather isn't supposed to be possible, and any space battle he is in causes my game to crash and autoresolving always results in a complete loss of my forces. Is there any way to just cut him out of the files?

Jul 11 2013, 10:21pm Anchor

Look in the XML file UniqueUnits, then search for Rogue_Shadow and delete it.

Jul 12 2013, 1:13am Anchor

Removing the entire segment causes an exception error and refuses to load any saved games, but new games have started. For what it's worth, it seems to have an unusual code (spaceunit instead of uniqueunit; changing this does nothing) and appears as [MISSING] ingame. Do I have to just start over with him removed?

Edited by: LurkerGuest

Jul 12 2013, 1:51am Anchor

Any time you remove something like a unit that was currently in use by a save file, it corrupts the save file. You'll have to delete the save and restart.

Jul 31 2013, 10:02am Anchor

The death star How to build not?

Nov 28 2013, 4:41pm Anchor

IG-88A on land is a vehicle. Other IG-88 are droid infantry. So they need different repair stations. Not sure if bug, but strange.

Reply to Thread
click to sign in and post

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.