Homeworld 2 meets Star Trek: Armada 2. Set in over all four Star Trek eras you will find three superbly balanced factions to face off against one another, the Alpha Quadrant superpowers! The versatile United Federation of Planets, the formidable Klingon Defence Force and the enigmatic Romulan Star Empire.

Forum Thread
by member
  Posts  
Bug Reports (Mods : Star Trek: Continuum : Forum : Report Bugs Here : Bug Reports) Post Reply
Thread Options 1 2 3 4 5 6 7
herbyguitar
herbyguitar STC Developer
Aug 18 2011, 2:19pm Anchor

If you find any bugs or hiccups please tell us! We want this MOD to be as good as we can make it and with your help we will make it even better. Please include as much information as you can in your post.

Thank you all for your help and support.

MOD support is for HW2 V1.1

If you don't have V1.1 then you WILL have issues.

Edited by: herbyguitar

--

cig photo STC2-1.png

Aug 20 2011, 1:54pm Anchor

I will just start by posting my Problems with the mod. The Launcher works perfectly fine, though i can not switch bloom on, but i think thats due to it being the Moddb version (still waiting for desura).

1st: While setting up a skirmish, i can select the map, but the picture remains the same, some Homeworld 2 map picture.

2nd The skirmish does not start, it crashes to desktop during the loading screen. It gets to the point where it says: "loading level" and it crashes afterward without any kind of error report or message telling me what happened.

The error report in the launcher however tells me this:

code:
Sat Aug 20 19:35:26 2011
 UTIL -- filepath failure, path doesn't exists 'C:\Program Files (x86)\Sierra\Homeworld2\data\locale\English'
 Uing ..profiles\ for profiles folder
 GAME -- Using player profile Custer85
 Changing from a 32 bit colour depth in winNT (6.1 build 7601), Service Pack 1
 Using NVIDIA Corporation's 4.1.0 GeForce GTX 460/PCI/SSE2 renderer (Suspected driver is nvoglnt.dll 0)
 SOUND -- created destination [ fdaudio ], handle [ 4 ] with [ 48 ] channels created
 SOUND -- created destination [ fda streamer ], handle [ 5 ] with [ 8 ] channels created
 Build name: Sajuuk-Khar - AutoBuild3498 - Ordered by smmatte
 Built by  : mrbuild
 Data path : C:\Program Files (x86)\Sierra\Homeworld2\data
 No mapping for font 'GenericSubtitleFont' - using 'default'
 Resetting fp control word.
 CmdLine: -mod STC_main.big;STC_shader2.big;STC_fonts.big -w 1280 -h 960
 do not show again has not been hooked up properly for this dialog.  you must give your message a name
 Starting Level: data:LevelData\Multiplayer\Invasion_TNG\COLONY DEFENSE.LEVEL
 Error: Mesh with radius greater then 20km (Joint0 | Joint0_mesh) -- FATAL EXIT -- parentmesh/946:! --stack trace-- 0x009BE27F: ParentMesh::computeBoundingSphere           (C:\Program Files (x86)\Sierra\Homeworld2\Bin\Release\objects.dll) 0x009BE4FB: ParentMesh::getBoundingSphere               (C:\Program Files (x86)\Sierra\Homeworld2\Bin\Release\objects.dll) 0x004653E7: GSLobbySessionDesc::operator=               (C:\Program Files (x86)\Sierra\Homeworld2\Bin\Release\Homeworld2.exe) 0x004301F7: GSLobbySessionDesc::operator=               (C:\Program Files (x86)\Sierra\Homeworld2\Bin\Release\Homeworld2.exe) 0x0046FC14: GSLobbySessionDesc::operator=               (C:\Program Files (x86)\Sierra\Homeworld2\Bin\Release\Homeworld2.exe) 0x00B24749: lua_error                                   (C:\Program Files (x86)\Sierra\Homeworld2\Bin\Release\lua.dll) 0x00B2BF45: lua_settagmethod                            (C:\Program Files (x86)\Sierra\Homeworld2\Bin\Release\lua.dll) 0x00B24751: lua_error                                   (C:\Program Files (x86)\Sierra\Homeworld2\Bin\Release\lua.dll) 0x00B247EE: lua_error                                   (C:\Program Files (x86)\Sierra\Homeworld2\Bin\Release\lua.dll) 0x00B2481E: lua_call                                    (C:\Program Files (x86)\Sierra\Homeworld2\Bin\Release\lua.dll) 0x00B24A13: lua_dobuffer                                (C:\Program Files (x86)\Sierra\Homeworld2\Bin\Release\lua.dll) 0x0046C43F: GSLobbySessionDesc::operator=               (C:\Program Files (x86)\Sierra\Homeworld2\Bin\Release\Homeworld2.exe) 0x00476061: GSLobbySessionDesc::operator=               (C:\Program Files (x86)\Sierra\Homeworld2\Bin\Release\Homeworld2.exe) 0x00442A1E: GSLobbySessionDesc::operator=               (C:\Program Files (x86)\Sierra\Homeworld2\Bin\Release\Homeworld2.exe) 0x004317E4: GSLobbySessionDesc::operator=               (C:\Program Files (x86)\Sierra\Homeworld2\Bin\Release\Homeworld2.exe) 0x00588138: getLibraryID                                (C:\Program Files (x86)\Sierra\Homeworld2\Bin\Release\Homeworld2.exe) 0x0053B602: GSTracker::operator=                        (C:\Program Files (x86)\Sierra\Homeworld2\Bin\Release\Homeworld2.exe) 0x0053C719: GSTracker::operator=                        (C:\Program Files (x86)\Sierra\Homeworld2\Bin\Release\Homeworld2.exe) 0x00B4112F: LuaBinding::Obj::Dispatcher                 (C:\Program Files (x86)\Sierra\Homeworld2\Bin\Release\LuaConfig.dll) 0x00B24749: lua_error                                   (C:\Program Files (x86)\Sierra\Homeworld2\Bin\Release\lua.dll) 0x00B2BF45: lua_settagmethod                            (C:\Program Files (x86)\Sierra\Homeworld2\Bin\Release\lua.dll) 0x00B24751: lua_error                                   (C:\Program Files (x86)\Sierra\Homeworld2\Bin\Release\lua.dll) 0x00B247EE: lua_error                                   (C:\Program Files (x86)\Sierra\Homeworld2\Bin\Release\lua.dll) 0x00B2481E: lua_call                                    (C:\Program Files (x86)\Sierra\Homeworld2\Bin\Release\lua.dll)  0x004915F7: GSLobbySessionDesc::operator=               (C:\Program Files (x86)\Sierra\Homeworld2\Bin\Release\Homeworld2.exe) 0x004948BF: GSLobbySessionDesc::operator=               (C:\Program Files (x86)\Sierra\Homeworld2\Bin\Release\Homeworld2.exe) 0x0049034A: GSLobbySessionDesc::operator=               (C:\Program Files (x86)\Sierra\Homeworld2\Bin\Release\Homeworld2.exe) 0x004908DE: GSLobbySessionDesc::operator=               (C:\Program Files (x86)\Sierra\Homeworld2\Bin\Release\Homeworld2.exe) 0x00490961: GSLobbySessionDesc::operator=               (C:\Program Files (x86)\Sierra\Homeworld2\Bin\Release\Homeworld2.exe) 0x75000076: ExtractIconExW                              (C:\Windows\syswow64\SHELL32.dll)


My System:

Windows 7 Professional 64bit (lates service pack), nVidia GeForce 460 GTX, 6 Gb RAM, Intel Dual Core 2.66 GHz (running at 3.0 GHz)

Edited by: Custer85

Aug 20 2011, 3:26pm Anchor

You appear to be using the 1.0 version of the game, most mods require v1.1 to work properly

Aug 20 2011, 4:51pm Anchor

ok i don't know if this is a bug or not. When i am in the main menu evrything lags alot.

Aug 20 2011, 5:35pm Anchor

Thx, my Problem is solved, the 1.1 patch was missing. Game runs perfectly fine now!

herbyguitar
herbyguitar STC Developer
Aug 20 2011, 6:48pm Anchor

@ scorpio23. Try disabling/enabling V synch. See if that makes a difference.

--

cig photo STC2-1.png

Aug 20 2011, 7:42pm Anchor

Cant play Homeworld 2 and the Mod. Heavy slow downs when i zoom in/out and move the Cam in some direction.

Edited by: Stargazer42

Aug 20 2011, 8:22pm Anchor

Hi, the game will not work with the maps or invasion but does work with HW2 maps. I don't understand this but here is me error log i hope it helps, besides that the game is awsome I would still like to play the rest though, Thank you.

Sat Aug 20 20:13:36 2011
UTIL -- filepath failure, path doesn't exists 'C:\Program Files\Sierra\Homeworld2\data\locale\English'
Uing ..profiles\ for profiles folder
GAME -- Using player profile Gregory
Changing from a 32 bit colour depth in winNT (6.0 build 6002), Service Pack 2
Using NVIDIA Corporation's 3.3.0 GeForce 8600 GT/PCI/SSE2/3DNOW! renderer (Suspected driver is nvoglnt.dll 0)
SOUND -- created destination [ fdaudio ], handle [ 4 ] with [ 48 ] channels created
SOUND -- created destination [ fda streamer ], handle [ 5 ] with [ 8 ] channels created
Build name: Sajuuk-Khar - AutoBuild3498 - Ordered by smmatte
Built by : mrbuild
Data path : C:\Program Files\Sierra\Homeworld2\data
No mapping for font 'GenericSubtitleFont' - using 'default'
Resetting fp control word.
CmdLine: -mod STC_main.big;STC_shader2.big;STC_fonts.big
do not show again has not been hooked up properly for this dialog. you must give your message a name
Starting Level: data:LevelData\Multiplayer\Invasion_TNG\COLONY DEFENSE.LEVEL
RESEARCH ERROR: target of "KNG_ENT_Research_Tree" is invalid (target is ""), setting to no upgrade target
RESEARCH ERROR: target of "KNG_TOS_Research_Tree" is invalid (target is ""), setting to no upgrade target
RESEARCH ERROR: target of "KNG_TMP_Research_Tree" is invalid (target is ""), setting to no upgrade target
Error: Mesh with radius greater then 20km (Joint0 | Joint0_mesh) -- FATAL EXIT -- parentmesh/946:! --stack trace-- 0x0022E27F: ParentMesh::computeBoundingSphere (C:\Program Files\Sierra\Homeworld2\Bin\Release\objects.dll) 0x0022E4FB: ParentMesh::getBoundingSphere (C:\Program Files\Sierra\Homeworld2\Bin\Release\objects.dll) 0x004653E7: GSLobbySessionDesc::operator= (C:\Program Files\Sierra\Homeworld2\Bin\Release\Homeworld2.exe) 0x004301F7: GSLobbySessionDesc::operator= (C:\Program Files\Sierra\Homeworld2\Bin\Release\Homeworld2.exe) 0x0046FC14: GSLobbySessionDesc::operator= (C:\Program Files\Sierra\Homeworld2\Bin\Release\Homeworld2.exe) 0x00394749: lua_error (C:\Program Files\Sierra\Homeworld2\Bin\Release\lua.dll) 0x0039BF45: lua_settagmethod (C:\Program Files\Sierra\Homeworld2\Bin\Release\lua.dll) 0x00394751: lua_error (C:\Program Files\Sierra\Homeworld2\Bin\Release\lua.dll) 0x003947EE: lua_error (C:\Program Files\Sierra\Homeworld2\Bin\Release\lua.dll) 0x0039481E: lua_call (C:\Program Files\Sierra\Homeworld2\Bin\Release\lua.dll) 0x00394A13: lua_dobuffer (C:\Program Files\Sierra\Homeworld2\Bin\Release\lua.dll) 0x0046C43F: GSLobbySessionDesc::operator= (C:\Program Files\Sierra\Homeworld2\Bin\Release\Homeworld2.exe) 0x00476061: GSLobbySessionDesc::operator= (C:\Program Files\Sierra\Homeworld2\Bin\Release\Homeworld2.exe) 0x00442A1E: GSLobbySessionDesc::operator= (C:\Program Files\Sierra\Homeworld2\Bin\Release\Homeworld2.exe) 0x004317E4: GSLobbySessionDesc::operator= (C:\Program Files\Sierra\Homeworld2\Bin\Release\Homeworld2.exe) 0x00588138: getLibraryID (C:\Program Files\Sierra\Homeworld2\Bin\Release\Homeworld2.exe) 0x0053B602: GSTracker::operator= (C:\Program Files\Sierra\Homeworld2\Bin\Release\Homeworld2.exe) 0x0053C719: GSTracker::operator= (C:\Program Files\Sierra\Homeworld2\Bin\Release\Homeworld2.exe) 0x003B112F: LuaBinding::Obj::Dispatcher (C:\Program Files\Sierra\Homeworld2\Bin\Release\LuaConfig.dll) 0x00394749: lua_error (C:\Program Files\Sierra\Homeworld2\Bin\Release\lua.dll) 0x0039BF45: lua_settagmethod (C:\Program Files\Sierra\Homeworld2\Bin\Release\lua.dll) 0x00394751: lua_error (C:\Program Files\Sierra\Homeworld2\Bin\Release\lua.dll) 0x003947EE: lua_error (C:\Program Files\Sierra\Homeworld2\Bin\Release\lua.dll) 0x0039481E: lua_call (C:\Program Files\Sierra\Homeworld2\Bin\Release\lua.dll) 0x004915F7: GSLobbySessionDesc::operator= (C:\Program Files\Sierra\Homeworld2\Bin\Release\Homeworld2.exe) 0x004948BF: GSLobbySessionDesc::operator= (C:\Program Files\Sierra\Homeworld2\Bin\Release\Homeworld2.exe) 0x0049034A: GSLobbySessionDesc::operator= (C:\Program Files\Sierra\Homeworld2\Bin\Release\Homeworld2.exe)

Nathanius
O
N
L
I
N
E
Nathanius STC Developer
Aug 20 2011, 9:06pm Anchor

@ singlepochi

If the game is very very slow try enabling Vsync, I myself need to have it on for the game to play properly

@Greg1973H

You seem to have the same error that Custer85 had, is your Homeworld 2 patched to v1.1?

--

Nathan
煌内森
ネイサンモルラ
내슨올라
เนิะทาน


Remember, no matter where you go, there you are.

Aug 20 2011, 10:24pm Anchor

Damn Nvidia control panel forgot about the Vsync there :( but now works Fine :P.
Thx for Help and Thx for the Mod.

Aug 21 2011, 4:11pm Anchor
Someone wrote:RESEARCH ERROR: target of "KNG_ENT_Research_Tree" is invalid (target is ""), setting to no upgrade target

RESEARCH ERROR: target of "KNG_TOS_Research_Tree" is invalid (target is ""), setting to no upgrade target

RESEARCH ERROR: target of "KNG_TMP_Research_Tree" is invalid (target is ""), setting to no upgrade target


ENT, TOS, TMP? :D Yu guys are up to something, right? looking foreward and hoping for Release beta :D

Edited by: Custer85

Stargazer42
Stargazer42 STC Developer
Aug 21 2011, 6:34pm Anchor

HUSH! ;)
No, really: it seems that there're still some old STHW2 files in our working dir, which doesn't belong there anymore... no false hopes :P

--

User Posted Image
Your advertisement could be here!

Aug 21 2011, 11:06pm Anchor

Hi,
Where would i get the 1.1 patch?

Scrap that, i found it and will see if that fixes the issue.
Thank you for your help.

Aug 22 2011, 12:52am Anchor

@greg1973H : Moddb.com This is were you would get it from

Aug 22 2011, 3:21am Anchor

There is Romulan Torpedo Turret build option but there is no research available for me to research it.

Nathanius
O
N
L
I
N
E
Nathanius STC Developer
Aug 22 2011, 6:02am Anchor

@ Casojin

Name = "Rom_TNG_TorpedoTurretTech", RequiredResearch = "Rom_TNG_ShipyardTech",

Good spot! We changed the research tree there, but didn't put this across to the Romulan research file, our apologies! :(

--

Nathan
煌内森
ネイサンモルラ
내슨올라
เนิะทาน


Remember, no matter where you go, there you are.

Aug 22 2011, 7:57am Anchor

hey guys is there a missing ship in the romulan fleet cause when iwas reseachibg i found a missing ship in the destroyer research thing i think it is called the draconious

Aug 22 2011, 8:14am Anchor

First off, great mod, I'm not that much of a star trek fan but it's fun to play and a visual spectacle even with the 1.0 shaders, which brings me to my problem.

Despite having a computer that should be perfectly capable despite being rather outdated (Pentium 4 3.2ghz HT, Nvidia Geforce 7800GS AGP, 2GB RAM ect) of running the game with the 2.0 shaders, I get some very odd visual errors when I try, most noticable being some very unsightly banding in place of a smooth shadow on the planets and a seeming lack of the other features that the 2.0 shaders boast, such as the improved lighting and normal mapping. The game is patched to 1.1 and I have the most recent graphics drivers.

Here's what I'm talking about:

Any help is much appreciated :)

Aug 22 2011, 8:41am Anchor

i hgave 1.1 installed, and im using desura. I have double and triple checked its all installed correctly, but when i run the mod, its just vanilla HW2? Any suggestions.

Temeter
Temeter Official Tester
Aug 22 2011, 11:09am Anchor

So, ive played the mod a bit and encountered a few problems. HW2 is updated to 1.1, VSynch activated and other mods are working without problems. Well, at least not with more problems as they shoud have^^

First, and this is the most annoying problem, there is lag in the late game. There is no better way to ruin the graphical awesomeness of this mod than this continuous lag. The Rearm Mod has exactly the same problem, which is caused by having to much ships with construction abilities (subsystems, etc) at the same time. Pouk fixed this problem for the next version of the rearm mod.
I also had three crashes in my earlier games a few seconds after an enemy starbase finally exploded. This happened very seldom and i don't have an error log.

Although your launcher works for me, he always shows me a few times Runtime Error 216 at 0002AAD0 when he is supposed to close.

Then ive got two minor visual bugs. Planets are in front of the blue sensor field and the light on the map with the borg hub is flickering.

Then about the gameplay: The ships have inherited a preference to dive down on the enemy from the gunboats, while a part of the fleet attacks directly and draws most of the enemy fire. This causes sometimes unnecessary losses.
And i dont know if its a bug, but the freighters cant process scrap. That makes salvaging wrecks pretty much useless, as long as they aren't directly at your base.
The docking sequences are also a bit slow. Don't get me wrong, they look absolutely awesome, but they are sometimes painfully slow. Speeding them a bit up won't hurt, at least in my eyes.

Aug 22 2011, 2:15pm Anchor

i have the same problem it just plays the vanilla homeworld 2.

Stargazer42
Stargazer42 STC Developer
Aug 22 2011, 3:05pm Anchor

DESURA VERSION:
Desura puts the STC_Desura.big file in the base Homeworld2 directory, which causes the mod to not launch (just stock HW2). Moving this file into the Data folder solves the problem.
- I'm not using Desura, this is a solution by Bird_of_Prey.

Anyone using Desura for distribution please note, the folder you make the MCF file from is not included in the MCF file itself!

Edited by: Stargazer42

--

User Posted Image
Your advertisement could be here!

Aug 22 2011, 4:17pm Anchor

Ah ok, i allready figured that out, but the Desura version starts the mod without using the launcher.

Aug 22 2011, 10:19pm Anchor

There is another interesting bug I've found. When the ships are attacking in close formation, they usually ram one another. This happens more often with larger ships (Fed ships attacking a Borg cube would ram into a cube and don't shoot as much as it should).

Maybe the attack pattern should be readjusted a bit...

Aug 23 2011, 4:51pm Anchor

The Desura version still does not work for me properly. I can launch the game, but I can not use the launcher and therefore not change the resolution and shaderversion.

Reply to Thread
click to sign in and post

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.