Full concept MODIFICATION of S.T.A.L.K.E.R. Call of Pripyat that touches every game aspect including textures, sfx, music, weapons, A.I., items, weather, mutants, difficulty and much much more!

Forum Thread
  Posts  
Vancer2's All Weapons upgrades - 2.2 Compatible (Games : S.T.A.L.K.E.R.: Call of Pripyat : Mods : MISERY : Forum : Mod optimization : Vancer2's All Weapons upgrades - 2.2 Compatible) Post Reply
Thread Options 1 2 3 4 5 6 7 8 9
Aug 27 2013 Anchor

Misery 2.2 Upgrades Download -----> Here

New versions for each class available!! Pick the one corresponding to the character class.
Links updated as of 11/29/2017

Recon
Sniper
Assault

Changes:
The VSS Tide was accidently skipped over, (whoops) You can now unlock all the upgrades for it. Credit to GoldminerJoe-89 for pointing that out.
Fixes crashes with upgrading or selling items that have preinstalled upgrades. Enjoy :D


Attention. I do not have an item spawner yet so I can't test if every weapon wont crash when you go to upgrade it. If you hover over an upgrade and it crashes please post the following.

1. Crash log (located in C:\Program Files (x86)\Steam\steamapps\common\stalker call of pripyat\_appdata_\logs
2. The type of class you are playing.
3. What were you doing when the crash occurred.
4. What weapon you were using. where you using it.

Credit to nokte for helping me out. Couldn't have done it without him.







Attention I made a new mini mod for Mp5ings' The Armed Zone made by Mp5ing his mod adds over 30 new weapons with neat grenade launcher sights! including an MP40, Dual FN57 pistols. an M79 grenade launcher and much more! Plus, If you love revolvers his mod has it.
Download his mod there. Moddb.com
Then download my mini mod for it here
Moddb.com
My mini mod does exactly the same thing as this mod here

Everything for regular Misery 2.1.1 is down below. :)

NEW UPDATE FOR WEAPONS
IF YOUR GAME CRASHES READ SUPPORT BELOW THE DOWNLOADS FOR AWUU.

Mediafire.com

Armor unlocks now available for Misery 2.1.1
ALL ARMOR UNLOCKED UPGRADES Downloads will be above this bar.
======================================================

ALL WEAPON UPGRADES UNLOCKED Downloads will be below this bar.
VERSION 1.4.8 IS OUT NOW FOR MISERY 2.1.1

BE SURE TO BACK UP YOUR GAMEDATA\CONFIG\WEAPONS FOLDER BEFORE INSTALL,
This mod requires a new game. I know I'm sorry, that's just the way it is.

This is for the ARMED ZONE


~~~~~~~~ You now have have three files to download from, Download the file for the class you're currently using and extract into your root Stalker Call of Pripyat Folder.
The Assault Class
Mediafire.com
The Recon Class
Mediafire.com
The Sniper Class
Mediafire.com

The 3 below are for VANILLA MISERY.. Note DONT GET THE CAMO AKS74U (still crashes game, I will fix this soon)

Assaulter
Mediafire.com
Recon
Mediafire.com
Sniper
Mediafire.com


========================== FOR SUPPORT ABOUT CRASHING READ BELOW===============

If your game crashes after installing my mod I will need to know 3 things.

1. Crash log (located in C:\Program Files (x86)\Steam\steamapps\common\stalker call of pripyat\_appdata_\logs
2. The type of class you are playing.
3. What were you doing when the crash occurred.
4. What weapon you were using. where you using it.

Credit to nokte for helpinng me out. Couldn't have done it without him.



CHANGELOG LISTED BELOW
Removed pre-installed upgrades on custom weapons that caused the game to crash due to the mod. To offset the removal I have cut the price on the removed upgrades in half
Reduced the cost of the Custom Beretta's Autofire upgrade from 4680 to 2340
Reduced the cost of the Camouflaged Beretta Silencer from 1380 to 690
Reduced the cost of Snags' AK74u 1st Reliability upgrade from 2720 to 1360
Reduced the cost of the Browning High Powered Camouflaged Integrated barrel lifting compensator (recoil upgrade) from 1720 to 860
Reduced the cost of the MP5A3 Customized RoF upgrade from 3360 to 1680
Reduced the cost of Streloks SG 550 Customized Rof upgrade from 4880 to 2440
Reduced the cost of the SG 550 Customized Recoil upgrade from 3820 to 1920
Reduced the cost of the Decorated TOZ 34 Barrel balancing system upgrade from 1340 to 670
Reduced the cost of the FN FAL "Azzasin's Creeping bolt installation upgrade from 3710 to 1855

No longer crashes when you load a game that has an npc with one of the following weapons equipped or a trader spawns with Winchester Camo, Browing HP, MP5, Sig 550 Customized, FNFAL Customized,

[size=10]NOTE I will be editing all AK rifles to be able to use the GP-25
launcher sights. I have so far as of typing been able to use the AKM
and the AKS-74 this a treat for all of you[/size] ]

DOWNLOAD NOW

I have fixed several iron sight problems that were not fixed from version 2.0 (go figure) You can now Aim with the real Grenade launcher sight on the AK47M :] This version REQUIRES A NEW GAME (sorry)

While i know this will not be the final version, Require any bug related crashes with logs that show relevant information such as up_first_mp5_e or
anything similar this is related to my mod so please post in this section or message me and Ill make a new version as Quick as possible. I will try to the best of my abilities to troubleshoot each and every problem. Now get out their and have some fun.


Everything Below this line ----------------- is for Version 2.0 so ignore that

NEW UPDATE SEPTEMBER 10ND VERSION 1.6 FOR WEAPON UPGRADES
NOTE ON THURSDAY THE 12TH OF SEPTEMBER ILL BE GOING offline for a while so I wont be able to upload new version of the weapon upgrades mini mod. I cant give a specific date when Ill be back but somewhere around october Ill be back.
So until then WeaponsUpgradeV16 will be the latest Version. Ill still be able to post forum replies and keep up with you guys from my mobile phone and such.

Im uploading this mod for those that dont like the upgrade system that makes you go down one path of upgrading your weapons and blocks you from going down the other path.

A word of advice so I dont get labeled as the "bad guy" so follow the advice below!!!!

if its installed in steam
Navigate to your C:\Program Files (x86)\Steam\steamapps\common\stalker call of pripyat\gamedata\configs\weapons\upgrades
make a new folder in here and select all the files in upgrades and copy and paste the files to the new folder you just made.

if you dont have it for steam then its probably (taking a guess C:\Program Files\Bitcomposer Games\S.T.A.L.K.E.R.: Call of Pripyat\gamedata\configs\weapons\upgrades.
same precaution as above
make a new folder in here and select all the files in upgrades and copy and paste the files to the new folder you just made.


So what This mini mod does is --

Unlocks tier 3 upgrades for weapons standard and above.


worn weapons and rusty weapons dont get all upgrades as they can only get tier 1 unlocks so theres no point in modifying those.

EDIT NEW FILE HOST NOW SO its much easier
VERSION 1.5 IS OUT NOW AS OF SEPTEMBER 6ND

Weapon Upgrades ^^
New update for Weapons Unlocks this is now version 1.2
Changelog 1.0
Changed various bugs and crashes with upgrades with the AK family

Version 1.1

Added the ability for the gsh18 for the 3 round burst which was already there but disabled by default

Fixed Negative recoil for most automatic weapons

Fixed crash that could occur right upon clicking an abakan to upgrade it.

Version 1.2

Fixed iron sight alignment of the AKM

Fixed a Crash with the GP100 after clicking the 1st upgrade on the bottom 4th upgrade.

Added all standard upgrades availabed for the Usp45.
Version 1.3
Fixed Crash that occurred right after clicking on an FN F2000

Added All upgrades to the Stechkin APS

Added all upgrades that were appearing as unavailable for the Makarov which was resulting in the upgrade problem for the Stechkin

Enabled the tier 3 upgrades for the Sig P220.

Removed a built in upgrade for the Browning Hi Powered Camo version which was causing a crash. (I offset this by making the upgrade cost free)
Version 1.4

Fixed Crash That would occur right after clicking on Nimbles GP37 in the upgrade screen

Version 1.5

fixed Crash due to encountering npcs with custom SIG 550

Fixed crash upon entering yanov due to Snag's AK74u

Fixed crash that would occur after receiving The upgraded USP from Nimble

Added tier 3 upgrades to the mp5

Version 1.6

Added Missing Tier 3 upgrades to Winchester1300,

Fixed Crash occuring upon an NPC spawning with a Camouflaged Beretta,

Fixed Crash that Occured after getting within Meters of the Stash Containing Streloks Customised Sig 550.

Version 1.7
Fixed a crash that occurs when you either bought or spawned a Winchester camoflauged version. (spawning required an outside program) Credits to this fix goes to Nokte :]

Version 1.8

Added AKS-74u camo unlocks. (oops) Thanks to windy_day for bringing this to my attention =D


Edit reuploaded 1.7 I forgot to add the FN FAL fix SO you have to redownload. Its ok it wont corrupt or destroy anything I promise. :]
Added Custom Sig550 Upgrade tree to the FNFAL para Upgrade menu removed the third Scope upgrade for the Fn Fal para which caused Crashes. Credit to nokte for the entire file. :]
Mediafire.com

If your game is crashing because of previous upgraded weapons remove mod and put the backup files you made and
find Alife.ltx
Its in Gamedata\Configs

go to

switch_distance = 300

and set it to 10

load up your game and then go to a desolate area preferably in the north eastern area of the boiler anomaly in zaton i mean go REALLY NORTHEAST OF THAT ANOMALY and save. then exit your game. and change

switch_distance = 10
back to
switch_distance = 300

then reinstall my mod
and everything should be back to normal.

credit to
KCS123 for the fix

________________________________
Make sure you back up your upgrades folder first. Im not responsible for any damage, loss of life, data, probing, raping, etc.

Credits to Necromunger Necromunger for helping me with editing data and helping fix my spas-12 crash before they patched to 2.02 but his help gave me more of an idea on what i was doing

PS. This is THE very first mod I have ever released for anything period so.... no pressure right. Send all hate mail I mean crashlogs to me via pm
IF your game crashes go to your root game folder stalker call of pripyat\_appdata_\logs
and upload your xray.xxxx.log where xxxx is your name and that will give me a better understanding of what happened.

Again Thx for understanding that this is my VERY First mod published. I may have another mod in the works ;]

re added download link for 2.0.2 quick fix

NEW FILE FOR DOWNLOAD Ive now uploaded a mod that gives you the ability to get all upgrades for armor
Since I have no training at HTML editing this Thread is just going to really plain font. >.>1st step BACK THOSE FILES UP
Wherever you installed your Call of Pripyat go to

gamedata\configs\misc\items\outfit_upgrades and backup the files in there next download this file

Mediafire.com

Armor upgrades ^^
and extract it to gamedata\configs\misc\items\outfit_upgrades
Now enjoy your ability to upgrade every aspect of your suit AND helmet :]Same advisory as above

NEW UPDATE FOR ARMOR 1.1

Update 1.1

Fixed missing Icon descriptions for the ExoSkeleton.

expect lots of updates when Misery 2.2 comes out,

Edited by: Vancer2

Aug 28 2013 Anchor

THANK YOU X1000!
I was looking for something like this! Is it possible to unlock all armor upgrades aswell?

Aug 28 2013 Anchor

Yes as a matter of fact Ive already done that and have been using that for myself as well xD. The reason that the beretta and mp5 weapon files are in there are because of a crash as a certain preinstalled upgrade causes a crash whenever a certain npc is spawned with it so I fixed that but you can fix that by adding the upgrade yourself. Ill add the mod for armor as soon as I can :] AKA Starting now

Updates with Armor upgrade mod

Aug 28 2013 Anchor

Thanks a million mate! I'm finding that some weapons when you have to many recoil upgrades the gun has negative recoil as in when you shoot the gun aims lower :D so it is best to check the recoil of the gun after each upgrade to get the perfect recoil that suits you.

Edited : The download link for the armor upgrades isn't working for me :|
Figured it out you included the word file infront of the url

Edited by: Cabous

Aug 29 2013 Anchor

In that case Im going to have to tweak the variable's ;] also I currently have a working minimap in progress. Btw I have noticed the 3 round burst on the gsh18 doesnt work because the weapon class is set to a wrong variable and clicking on the alternate version of the abakan when you mod will crash for me So Im going to upload a quickfix soon. Keep me posted on any bugs you find :]

New update

Aug 30 2013 Anchor

You still need to fix the link for the armor upgrades. It might confuse some people. I'll post any bugs i fine when i come across some new ones.

Aug 30 2013 Anchor

Added New update for weapons upgrades

this is now version 1.2

New update

Version 1.3 is now released for Weapon upgrades

Edited by: Vancer2

Sep 2 2013 Anchor

Quick question what do i name the new folder that goes into upgrades folder?
Thank you in advance
Also do i need to start a new game?
Sorry for the inconvenience

Edited by: juanla16

Sep 2 2013 Anchor

Hello.
I have problems with the installation of the modification.
I should just replace the original files, or something more?
(sorry for my english)

Sep 2 2013 Anchor

Replace the original and your good to go
But MAke a backup of your files first if your not sure. I strive to make sure my mod will work but every now and then sumthing pops up.

New version available

Edited by: Vancer2

Sep 2 2013 Anchor

Thanks!!!!

Sep 3 2013 Anchor

Thanks, GSH18 was my best secondary till I couldn't upgrade it, so this fixes it and makes it the best secondary again :)

Sep 3 2013 Anchor

i have crash when i load game with modification((
is it for a weapon that has already improved?
(sorry for my eng)

"FATAL ERROR

[error]Expression : fatal error
[error]Function : inventory::upgrade::Group::can_install
[error]File : D:\prog_repository\sources\trunk\xrGame\inventory_upgrade_group.cpp
[error]Line : 101
[error]Description :
[error]Arguments : Loading item: Upgrade of inventory item [wpn_svu_nimble] (id = 33288) can`t be installed! Error = result_e_parents
"

Sep 3 2013 Anchor

Any way to undo a weapon update?

kcs123
kcs123 Just Kcs123
Sep 3 2013 Anchor

Stranger_AN wrote: i have crash when i load game with modification((
is it for a weapon that has already improved?
(sorry for my eng)

"FATAL ERROR

[error]Expression : fatal error
[error]Function : inventory::upgrade::Group::can_install
[error]File : D:\prog_repository\sources\trunk\xrGame\inventory_upgrade_group.cpp
[error]Line : 101
[error]Description :
[error]Arguments : Loading item: Upgrade of inventory item [wpn_svu_nimble] (id = 33288) can`t be installed! Error = result_e_parents
"


Most propably yes, try to load a savegame where you didn't upgraded any weapon. Or you can overwrite moded files from original misery files, reload saved game, go to trader and sell customized weapons. Save your game, exit, apply weapon modification and reload last saved game.

Similar thing have happened to me with other wepon mods.

--

Sep 3 2013 Anchor

Stranger_AN wrote: i have crash when i load game with modification((
is it for a weapon that has already improved?
(sorry for my eng)

"FATAL ERROR

[error]Expression : fatal error
[error]Function : inventory::upgrade::Group::can_install
[error]File : D:\prog_repository\sources\trunk\xrGame\inventory_upgrade_group.cpp
[error]Line : 101
[error]Description :
[error]Arguments : Loading item: Upgrade of inventory item [wpn_svu_nimble] (id = 33288) can`t be installed! Error = result_e_parents
"


That crash is a result of you loading the mod after you upgraded the weapons the old way. IF you followed the instructions in the thread you would have backed up your upgrade files and and the included weapon files. The next option is starting a New Game which will of course be the last course of action.

But this crash Is a result of upgrading the weapon after you had previously upgraded it before you installed my mod.

Sep 3 2013 Anchor

I have backup, i use it....but the problem is still there.
sig" sold and not on the list a trader.
probably have to start a new game (
(sorry for my english)
//FATAL ERROR

[error]Expression : fatal error
[error]Function : inventory::upgrade::Group::can_install
[error]File : D:\prog_repository\sources\trunk\xrGame\inventory_upgrade_group.cpp
[error]Line : 101
[error]Description :
[error]Arguments : Loading item: Upgrade of inventory item [wpn_sig550_custom] (id = 0) can`t be installed! Error = result_e_parents
//

Edited by: Stranger_AN

Sep 3 2013 Anchor

Looks Like Im going to have to put a Disclaimer stating that you need to remove any weapons youve upgraded before you install this mod or this will happen

Sep 3 2013 Anchor

Vancer2 wrote: Looks Like Im going to have to put a Disclaimer stating that you need to remove any weapons youve upgraded before you install this mod or this will happen

Probably yes .
But i remove all weapons, and this happened...
:confused:

kcs123
kcs123 Just Kcs123
Sep 4 2013 Anchor

@Stranger:AN, probably some of NPC near you have also some weapon that is altered by mod. Try to get away from NPC and save game and try mod. This is best advice I can give you before you start new game with this or another mod that alters weapons.

--

Sep 4 2013 Anchor

Because the game saves everything around you in memory you need to get as far away from people as possible. Otherwise the crash will continue to occur. But because it happens on a save game that crashes immediatly IT cant be helped. You just might need to start a new game anyway.

Edited by: Vancer2

kcs123
kcs123 Just Kcs123
Sep 4 2013 Anchor

Compleatly forgot abot this:

switch_distance = 300

set it to

switch_distance = 10

this is actualy quickfix if your game become corrupted, at least helps in some sittuations. Good advice, Vencer2, if that not help, new playtrough is only solution.

Edited by: kcs123

--

Sep 4 2013 Anchor

to all
Thanks for the idea.
Anyway If this does not work, i have to choose between maintaining progress or upgrades.
(sorry for my eng)

Sep 4 2013 Anchor

kcs123 wrote: Compleatly forgot abot this:

switch_distance = 300

set it to

switch_distance = 10

this is actualy quickfix if your game become corrupted, at least helps in some sittuations. Good advice, Vencer2, if that not help, new playtrough is only solution.


So you've tested this?? Thats great!! so now people dont have to restart their game. Ill put it in the main post right away

Sep 4 2013 Anchor

switch_distance = 10
Loading successfully, but when I walk up to the NPC - game crashed.
Probably will have to choose.(

Reply to thread
click to sign in and post

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.