Full concept MODIFICATION of S.T.A.L.K.E.R. Call of Pripyat that touches every game aspect including textures, sfx, music, weapons, A.I., items, weather, mutants, difficulty and much more!

Forum Thread
by member
Poll: Is the mod in your opinion "good"? (3,048 votes)
  Posts  
Bugs: (Mods : MISERY : Forum : General subjects : Bugs:) Post Reply
Thread Options 1 2 3 4 5 6 7 8 ... 128
Jan 19 2012, 10:48pm Anchor

I guess its really a balancing suggestion rather than a bug proper, but the zombies are really good. Their vision range and accuracy are really good for only being killable via headshot. If you could tone down their accuracy and vision range, it would make things more reasonable.

Jan 20 2012, 2:22am Anchor

Keep getting this log file when I play and the game crashes.  It seems to indicate that it is crashing b/c I am running out of RAM but that doesn't seem correct.  I'm monitoring RAM usage in game and it hovers around 2.3 GB.  I've played other STALKER mods that hover around 2.6 GB RAM used and they don't crash nearly this often (Have 4 GB RAM running Vista 32 bit).  Also, for whatever reason, the game refuses to run Enhanced Dynamic Lighting in DX10 mode.  Keeping all other settings the same, DX10 mode always crashes upon trying to load a save game.  I can run DX10 mode perfectly in Vanilla and even with other mods, but not with this mod for whatever reason.  Anyways, here is the end of my most recent crash log.  I've cranked settings down too, so the RAM should be well within the limits of what my machine has.  Also, what usually happens is that, when I can actually get the game to launch, it starts off fine, and as I head towards skadovsk the game starts freezing, then unfreezing, then freezing, then unfreezing, and eventually crashes.  I've yet to make it inside of skadovsk.

* GPU vertex cache: recognized, 24
* NVidia MGPU: Logical(2), Physical(1)
* NVidia MGPU: 2-Way SLI detected.
* Starting rendering as 2-GPU.
*** RESET [529 ms]
! Can't load texture 'j:\s.t.a.l.k.e.r. - call of pripyat\gamedata\textures\wpn\vsk94\upgrade_bump#.dds'
! Can't load texture 'j:\s.t.a.l.k.e.r. - call of pripyat\gamedata\textures\wpn\vsk94\upgrade_bump.dds'
! Can't load texture 'j:\s.t.a.l.k.e.r. - call of pripyat\gamedata\textures\wpn\vsk94\vsk94_bump#.dds'
! Can't load texture 'j:\s.t.a.l.k.e.r. - call of pripyat\gamedata\textures\wpn\vsk94\vsk94_bump.dds'
* MEMORY USAGE: 363328 K
* End of synchronization A[1] R[1]
* [win32]: free[69184 K], reserved[140976 K], committed[1886928 K]
* [ D3D ]: textures[868348 K]
* [x-ray]: crt heap[363974 K], process heap[12133 K], game lua[41931 K], render[3959 K]
* [x-ray]: economy: strings[27218 K], smem[7642 K]
* Saving spawns...
* Saving objects...
* [win32]: free[67132 K], reserved[140656 K], committed[1889300 K]
* [ D3D ]: textures[868348 K]
* [x-ray]: crt heap[366062 K], process heap[12133 K], game lua[43098 K], render[3959 K]
* [x-ray]: economy: strings[27218 K], smem[7642 K]
 
FATAL ERROR
 
[error]Expression    : fatal error
[error]Function      : out_of_memory_handler
[error]File          : D:\prog_repository\sources\trunk\xrCore\xrDebugNew.cpp
[error]Line          : 336
[error]Description   :
[error]Arguments     : Out of memory. Memory request: 4096 K
 

stack trace:

Edited by: BiggaWhat

[TZP]LoNer1
[TZP]LoNer1 Forum Badmin
Jan 20 2012, 2:29am Anchor

Misery is a heavy mod, and, this is your problem:

(Have 4 GB RAM running Vista 32 bit)

You need a 64bit version for optimal RAM use, vista's allocation of memory is higher than XP's, but again vista is a bit buggy sometimes, especially the 32bit version. i Recommend you to play on low / medium with the textures on half. DX10 is no option for you, because misery will kill it in DX10. You really need an upgrade in either software (W7 x64) or hardware.

--

#MDT CR / PR LEAD - FORUM RULES - PM ME - NEED HELP? - FAQ
You think your mod has it? Visit TZP for promotion and / or an invite to the team!
Jan 20 2012, 4:24am Anchor

I don't think its my problem though.  I literally have to turn the presets down to low or minimal, with static lighting, to get this mod to not crash.  Even then, RAM usage is not that much different from when settings are much higher.  Also, I can run other graphically heavy mods, such as Call of Pripyat Reloaded at maximum settings with DX10 lighting, all of the bells and whistles, and it doesn't crash.  I can't imagine my RAM amount making THAT big of a difference.  Hell, RAM usage is even higher in Reloaded and it works just fine.  I don't know what the problem is.  I'll try redownloading to see if I somehow got a corrupt version or something.

I even get the error "Not enough storage is available to process this command " in my crash logs even when it crashes at the main menu and I can't imagine the game running out of RAM just sitting at the main menu.

Jan 20 2012, 7:53am Anchor
BiggaWhat wrote:I don't think its my problem though.

Seeing you are the only one posting something equivallent,
maybe it's an idea to check your RAM and HDD for problems.

Jan 20 2012, 8:36am Anchor

Have you tried using the userva switch for Windows Vista/7 32-bit?

To enable the 3GB switch on Windows VistaTM or Windows 7:

  1. Right-click Command Prompt in the Accessories program group of the Start menu. Click Run as Administrator.
  2. At the command prompt, enter "bcdedit /set IncreaseUserVa 3072"
  3. Restart the computer.

Source: Scorpion.tordivel.no

Best to upgrade to Windows 7 64-bit, though.

Jan 20 2012, 12:41pm Anchor

Repair kit bug:

2 repair kits in stash, 2 in inventory.
Launch repair interface
do not repair anything
added another repair kit in inventory (3 now)
Perhaps RepairKit:cancel() is executed twice for some reason.

Jan 20 2012, 12:52pm Anchor

I'm not saying its not my problem, as I'm sure it is something unique to my system, I'm just saying I'm doubtful that its the RAM amount that is the problem, seeing as I can play other graphically intense mods and its fine.  I'll try enabling the 3 GB switch and rolling back drivers to see if that makes any difference

Edit:  Thanks for the 3GB switch advice, game isn't crashing anymore and I can crank up textures and run in DX10.  Awesome!  And yes I can't wait to build my new system with vista 7 64 bit, but that's not happening until this summer, so this will do for now.

Edited by: BiggaWhat

Jan 20 2012, 1:32pm Anchor

Well, I hope I can get some help here. My problem is that the game crashes when I start a new game, all is fine, but when it starts the loading screen, it loads a bit more than a half, and then it crashes.

Here hare mic rig specs:
CPU: Intel Core Duo E7200 @ 2.53Ghz
RAM: 6GB
Graphics Card: Radeon HD5750 1 GB

Here is the bug log:

Application: XRay Engine

Computer: IGNACIO-PC

User: Ignacio

Date: Friday, January 20, 2012 3:14:02 PM

 

Error Reason:

----------------------------------------

xrEngine.exe caused BREAKPOINT in module "C:\Program
Files\bitComposer Games\S.T.A.L.K.E.R. - Call of Pripyat\bin\xrCore.dll"
at 001B:001EE12E, xrDebug::backend()+174 byte(s)

 

User Message:

----------------------------------------

Expression    : fatal
error

Function      :
out_of_memory_handler

File          :
D:\prog_repository\sources\trunk\xrCore\xrDebugNew.cpp

Line          : 336

Description   : expression>

Arguments     : Out of
memory. Memory request: 29305 K

 

 

 

Registers:

----------------------------------------

EAX=167DEB20 
EBX=01C9E7E7  ECX=167DEB28  EDX=167DEC25

ESI=002188C8 
EDI=0000000C  FLG=00000216

EBP=00A0F1A0 
ESP=00A0E198  EIP=001EE12E

CS=001B  DS=0023  SS=0023 
ES=0023  FS=003B  GS=0000

 

CPU:

----------------------------------------

Number of Processors: 
2

Processors Descriptions:

1. Intel(R) Core(TM)2 Duo CPU     E7200 
@ 2.53GHz

2. Intel(R) Core(TM)2 Duo CPU     E7200 
@ 2.53GHz

 

Operating System:

----------------------------------------

OS Version:    Unknown
Service Pack 1

Build Number:  7601

 

Memory Usage:

----------------------------------------

Current Memory Load:        
88%

Total Physical Memory:      
3070 MB

Available Physical Memory:  
368 MB

Total Page File Memory:     
4095 MB

Available Page File Memory: 
2630 MB

Edited by: Vykromod

[TZP]LoNer1
[TZP]LoNer1 Forum Badmin
Jan 20 2012, 3:26pm Anchor

You are out of memory too, what system do you run? OS wise ofc. 32 or 64 bit? i think 32, because it cant allocate more than 2048Mb RAM....which should be way more if you are running 6GB's.

--

#MDT CR / PR LEAD - FORUM RULES - PM ME - NEED HELP? - FAQ
You think your mod has it? Visit TZP for promotion and / or an invite to the team!
Jan 20 2012, 4:56pm Anchor

I'm running on Win7 32. That means that I should change my CPU?

[TZP]LoNer1
[TZP]LoNer1 Forum Badmin
Jan 20 2012, 5:27pm Anchor

No ofcourse not, if you have a 64bit processor, you should change your operation system to 64bit as well :)

--

#MDT CR / PR LEAD - FORUM RULES - PM ME - NEED HELP? - FAQ
You think your mod has it? Visit TZP for promotion and / or an invite to the team!
Jan 20 2012, 5:35pm Anchor

Found another: I.imgur.com

FAR-15 Rifle. Sight is rather...not see through. Aiming with a fat red blotch is pretty difficult ^^ especially at longer ranges than normal like the gun describes.

Jan 20 2012, 6:18pm Anchor

- One bug I'm having is a crash whenever I attempt to load (or quickload - either way) a save where I have followers. To elaborate, I can acquire followers and have them tag along with me fine, without any issues, but if I choose to load a game with them following me, the game stops loading, and I have to exit out using the process menu (ctrl+alt+del), whereupon I get the standard "xRay 1.6 Engine has stopped working", which I assume has already appeared at the moment the loading stopped and simply stayed in the background.

Jan 20 2012, 6:42pm Anchor
[PPx wrote:L☢Ner1™]No ofcourse not, if you have a 64bit processor, you should change your operation system to 64bit as well :)

But my processor is based on 32bits not 64.

Jan 20 2012, 7:54pm Anchor

i have a little problem with dinamic hud. When using a gas mask or any other helmet, there are some strange green pixels on it.

Jan 21 2012, 12:48am Anchor

Can someone helpme? i cant even run the game now, i've just re-installed the whole game (clean install), then run it and everything's fine, then i install the mod (+ the patch) and CRASH (2 error windows and the report)

something like this:
1st:
cant find entry point of procedure ttapi_RunAllWorkers in the dinamic library xrCPU_Pipe.dll

2nd:
cant find entry point of procedure ?fill_auth_check_params@@YAXAAV?$xr_vector@Vshared_str@@V?$xalloc @Vshared_str@@@@@@0@Z in the dinamic library xrNetServer.dll

And the bug report:
Expression    : hGame
Function      : CEngineAPI::Initialize
File          : D:\prog_repository\sources\trunk\xrEngine\EngineAPI.cpp
Line          : 131
Description   : Game DLL raised exception during loading or there is no game DLL at all

What can i do?

BTW:  dunno if this helps
I have Windows 7 64bit
8Gb Ram

Edited by: Zorrow_Rage

Jan 21 2012, 2:05am Anchor

pls help,. geting annoying crash, everytime im geting close to skadovsk-ship!
FATAL ERROR

[error]Expression : fatal error
[error]Function : CInifile::r_string
[error]File : D:\prog_repository\sources\trunk\xrCore\Xr_ini.cpp
[error]Line : 513
[error]Description :
[error]Arguments : Can't find variable silencer_name in [wpn_gsh18]

stack trace:

game version 1.6.2; mod version: patch 1;Rig: Phenom II x4 965BE12GB DDR3 RAMATI HD 6970 2GB1TB spinpoint F3 HDD.

Jan 21 2012, 2:48am Anchor
Zealot644 wrote:Found another: I.imgur.com
FAR-15 Rifle. Sight is rather...not see through. Aiming with a fat red blotch is pretty difficult ^^ especially at longer ranges than normal like the gun describes.

I had the same problem, it is easily solved by raising your resolution. I changed to 1920x1080 and it looks like a red dot.

Jan 21 2012, 4:25am Anchor
  • Some ammo types (especially 7.62mm sniper ammo) has ZERO!! armor piercing property (see weapons.ltx), even in the AP variant of the ammo. As far as I know "k_pierce" only affect environment object piercing, "k_ap" is the armor piercing parameter.
  • With most ammo types caliber does not affect damage, yet 9x39mm, 7.62mm WW2 ammo and sniper ammo does affect damage drastically (up to x3 damage).
Jan 21 2012, 4:51am Anchor

CoP 1.6.02+Misery+Path 1.6.1+New Game:
[error]Expression : !m_error_code
[error]Function : raii_guard::~raii_guard
[error]File : D:\prog_repository\sources\trunk\xrServerEntities\script_storage.cpp
[error]Line : 748
[error]Description : g:\games\misery\gamedata\scripts\xr_logic.script:770: bad argument #1 to 'pairs' (table expected, got nil)
Departure is stable, when loading a save. A new game starts without problems. I think all of that took the duo two stalkers.

Edited by: xGeneral

Jan 21 2012, 5:32am Anchor

Everytime I quick save, and then quick load shortly after, the game crashes. When I close out and restart the game, it crashes again trying to load the save that's now corrupted...

I even tried multiple saves, they all crash the game after the initial crash.

Any solutions?

Jan 21 2012, 5:34am Anchor

Only bugs I've encountered are the scope upgrades doesn't work for the sks and mosin nagant, that and the misaligned sights, but i get the feeling you already know about those.

Jan 21 2012, 5:57am Anchor

Okay I just confirmed all saving/loading's f-ed for me.

I even waited till I'm " lost in the zone" and returned to the main menu before reloading, and immediately after I get a crash.

I don't think I'll be playing it much till this issue is sorted out, with no saving it's impossible to play.

Edited by: Jashin

Jan 21 2012, 6:17am Anchor

I chose the Uss Sniper.
The Gsh-18 is not perfect alligned.
I cant play only with static lighting if i set other lighting mod the game crashes, and if  i set textures quality on maximum level the game crash every time, i can play only if i set the texture quality on low level.
My artifacts reveletor doesn't work.
And i have a lot of crashes, like others when i save, when i load, when i die.

Edited by: loe92

Reply to Thread
click to sign in and post

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.