Full concept MODIFICATION of S.T.A.L.K.E.R. Call of Pripyat that touches every game aspect including textures, sfx, music, weapons, A.I., items, weather, mutants, difficulty and much more!

Forum Thread
by member
  Posts  
Bugs with "MISERY" + "Patch 2" installed (Mods : MISERY : Forum : General subjects : Bugs with "MISERY" + "Patch 2" installed) Locked
Thread Options 1 2 3 4 5
Jul 27 2012, 12:23am Anchor

To add to the bug list-

1. The two PDAs relating to sultan (Snag mission= 1st one found in dock cranes zaton and next jupiter train station), when selling them to owl, he offers 1k and 500 Ru repectively. However selling them gives me only half the amount i.e 500 and 250 Ru resp.. 

2. When negotiationg with the bandit in vano's case, you can negotiate a price to 5k Ru. But when i paid, only half the amount got reduced from my in-game money bank i.e. 2500 RU...

Edited by: aniket_d

Aug 1 2012, 7:38pm Anchor

Aug 1 2012, 10:49pm Anchor

The medic/doctor disappears for me in Zanton for no reason and I cannot get medical supplies I've patched it yes

N.Aaroe
N.Aaroe MDT Lead
Aug 2 2012, 12:52am Anchor
daddyrabbittts wrote:The medic/doctor disappears for me in Zanton for no reason and I cannot get medical supplies I've patched it yes

That is a part of the main storyline

--

Aug 5 2012, 9:23pm Anchor

I can't see the "TRADE", "BUY", "SELL" and "CURRENCY" parts of the UI. The buttons/banks are simply empty- no numbers displayed.

Aug 7 2012, 7:36pm Anchor

1.7.62x39 ap rounds are cheaper than the regular, and extremly over priced in my option, there around $1400.
2.When upgrading my exoskeleton i noticed that the plus 20% electric proctection add around 3 bars to the base stats, while the plus 20% flame only added 1 bar.
3. Nitro and the scientist cant upgrade sprint on my ecoskeleton.

Aug 7 2012, 7:57pm Anchor

I was excited to see this mod when i saw it however i was having some trouble and was wondering if someone could help me. i have the steam version of the game and have downloaded both the mod and the patch. the game opens fine but when i start a new game it gets most of the way through the load and crashes. i have tried many things already such as lowering graphics settings to medium changing the game data lines to true true and even uninstalling the game manually and re installing. i have a pretty good gaming computer and 4 gb RAM. so any help would be greatly appreciated thanks.

Aug 14 2012, 2:28pm Anchor
I'm so excited for this mod.However,i downloaded it,installed it,tried to play (through steam) and after smashing the play button it got me in the game.loading screen bla bla bla worked but the difficulty didnt have MISERY in it,thus it got me suspicious.I clicked on Enter the Zone and the game crashes.I uninstalled and installed again without the Patch 2 and it works,anyone know something?

Here's what the X-ray engine bug report said:

xrEngine.exe caused BREAKPOINT in module "c:\program files (x86)\steam\steamapps\common\stalker call of pripyat\bin\xrCore.dll" at 0023:0058E12E, xrDebug::backend()+174 byte(s)
Registers:
EAX=07A978D8  EBX=003C8440  ECX=07A978E0  EDX=07A97A53
ESI=005B88C8  EDI=0058E300  FLG=00200212
EBP=0018E8D8  ESP=0018D8D0  EIP=0058E12E

CS=0023  DS=002B  SS=002B  ES=002B  FS=0053  GS=002B

Aug 16 2012, 4:07pm Anchor

mine just dosn't work regardless

Aug 17 2012, 10:18am Anchor

every time i load a save during a game it crashes, even if i close the chapter it crashes i have to completely reopen the game.
I cant use the guide to go back to zaton it just crashes.

other than that its fine and im loving it (exept the zombies who can be anything from 1 shot with a pistol to near invincible) but being stuck in jupiter is getting boring.

Aug 17 2012, 3:46pm Anchor

this mod was definatley named after your feelings as you try to get it to work... can anyone help i have the steam version and with or without patch 2 it dosnt work. it has no problem starting than i hit new game it loads until the end and than crashes everytime. SOMEONE PLEASE HELP ME NO ONE SEEMS TO KNOW WHAT THE PROBLEM IS!

Aug 17 2012, 3:53pm Anchor

Not Sure if anyone else has dealt with this but i Got a G36(whatever) from Nimble and it says that it takes a 5.45x45 (i think) suppressor but when i bought one and attempted to equip it it wont give me the option.

Aug 17 2012, 4:33pm Anchor

i dont think you can suppress the g36

Aug 19 2012, 1:44am Anchor

I want to report that when I modified the sell quality price from 95% (steep as hell!) to about 55% (having some money troblues :/) I just finished the bloodsucker level went to the crane stalker camp to kill some bandits I found and sell their equipment onto owl I picked up a 90% AK74U (not sure of in-game name) I go to sell it to owl but it pops up with an error: trade_don't_make. I thought it was just owl glitching out but I went to every tradeable stalker in the skadovsk and they all have it, I even tried to sell my suit. I think it might be something to so with where I am in the story because I enjoyed about 4 hours of my modifications to the gun quality price no problem. I don't know if it's been encountered before but now I can't make money, I would also like to point out that I have negative money because for some reason to find out about the gas to kill the bloodsuckers in their lair I only had 1356RU for the 2000RU price but it still worked and I got -644RU.

Aug 25 2012, 3:07am Anchor

only real annoying bug or complain is the knife/binoculars, sometimes we simply dont notice when they were shot/biten off of our hands and hence never able to use them, which is FUCKING ANNOYING. i kill mutants with knife because is easier for an ok player, and obviously binoculars are useful. make them selleable items or something, or dont give the item the ability to be dropped off in the first place!

Aug 28 2012, 4:17am Anchor

i got this after a reinstall(i was trying to make zonewars and misery work together) and a fresh download and install of misery + patch, usign the steam copy and have played misery before on said copy
Expression    : fatal error
Function      : CInifile::r_string
File          : D:\prog_repository\sources\trunk\xrCore\Xr_ini.cpp
Line          : 513
Description   :
Arguments     : Can't find variable hud in [ammo_11.43x23_fmj]

Aug 28 2012, 1:42pm Anchor

I managed to circumvent my previous problem but now every time I try to start a game("Enter the zone") the game crashes right at the very end and an error message pops up saying that there is no disk in drive D and my options are to try again,cancel or continue. All of them result in a crash anyway and after I choose either of those another error message pops up saying xrEngine1.6.exe has stopped working.

Edited by: Dopubalimatu

Aug 28 2012, 3:09pm Anchor

The mod says I can attach suppressors to the G36 and F2000 but I cannot.
Also I do not get what the AEK-973 scope mount is for?

Sep 12 2012, 1:18pm Anchor

I have this bug (I think it was a bug in Stalker without Misery as well) that has to do with ammo/grenade types. It can be reproduced by doing the following:
1. load armor piercing ammo into a weapon with a grenade launcher attached -- say the AKM for example --
2. switch to grenade launcher and have it loaded with regular launcher ammo
3. switch to another weapon
4. save
5. load
6. switch to the weapon with the launcher
7. switch back from the launcher to the regular fire mode
--> now the weapon does NOT contain armor piercing rounds any more, just regular rounds.
Basically the ammo type is not saved correctly if the off hand weapon is in grenade launcher mode.
Also the grenade ammo type is not saved correctly if the off hand weapon is in regular firing mode.
Can this be fixed in Misery 2.0? Can this be fixed at all?

Sep 12 2012, 2:50pm Anchor

the aim of the famas weapon is off, the gun is displayed at the side of the screen rather then in the center, and wenever you try to upgrade the silencer on the famas the game crashes

Sep 13 2012, 2:14pm Anchor

I found these. Im playing on 4:3 ratio, with a FOV of 67,50

1. Sawn-off shotgun reload anim is bugged (Also goes for the fullsized BM16) : When reloading, the actor drops the empty shells, the right one stays in the bottom-right of the screen, which the actor then grabs and reinserts when he reloads. Pretty immersion breaking :'( NOTE: This does not occur at the default FOV.

2. Sawn-off reload sound (again, same goes for the fullsized BM16): When you reload after firing 1 shot with the sawed off, the reload sound is different: it sounds like the one from SoC. Is this intentional, or a bug? Sounds pretty weird to me. :S

3. APS Stechkin sights are still off. FAMAS aswell.

4. Uncle Yar's mission is a bit bugged: The zombies will attack you, no matter what. Its not a big deal, but Yar acting like a target dummy and soaking hundreds of rounds is breaking the immersion.

5. Blowout sirens are bugged, or just removed?

6. Kar98K could use some better anims. Lightning fast reload.

7. My Binocs seem to be missing since the sniping mission in Pripyat

8. Some prices are different in dialogs. (For example: Pilot offers me to move back to Zaton for 1000ru, even though I only have to pay half of it.)

9. Saving while having companions follow you causes the savegame to go corrupt. I think this is known, but just to be sure ^_^

10. Traders seem to be running out of supply? (for example, SVD ammo from Owl) Or is it intentional?

11. The shotgun have a pretty agressive sway, even though I picked the USS Assaulter spec. Notable on Sawn-off, but especially the Saiga.

12. I dont know if this is a bug or WIP, but Controllers only seem to use their melee/swipe attack on npcs, not their mind blast.

Sep 16 2012, 3:46pm Anchor
  • The M4A1 ejects spent casings from the left side of the receiver, even though the ejection port is clearly modeled on the right side of the weapon.
  • Also, when reloading the M4A1 the top of the magazine clips through the left side of the magazine well for a split second.

Edited by: infiniteMotion

Sep 22 2012, 7:56pm Anchor

i keep getting shot by random friendly npcs without a warning. this happened to me once in skadovsk and once outside. stalkers who appeared as friendly on the map just mowed me down for no apparent reason

RagingRapscallion wrote:i keep getting shot by random friendly npcs without a warning. this happened to me once in skadovsk and once outside. stalkers who appeared as friendly on the map just mowed me down for no apparent reason

oh nevermind, i was apparently just too retarded to install it properly. works fine now. awesome mod, really feels like what stalker should have been in the first place

Oct 11 2012, 3:49am Anchor

I haven't played much but from what I've played it's pretty smooth. My only problem is that whenever I die or after there's an update on a quest, such as me completing it or such as when you go with the bandits to the ship to kill the rookies and meet with them, after speaking with the leader it freezes up for about 30 seconds or so then goes back to normal. It also does something similar to this whenever I try to go to the menu or save/load my game, except the period of time is about 3-6 minutes of freezing.

My specs are as follows:

AMD Phenom II X6 1045T 2.7GHz
8GB DDR3 1333
AMD 785G Chipset
1.5TB 5400RPM SATA
MSI GeForce GT 430 2GB DDR3 (Part 
N430GT-MD2GD3-OC)
Windows 7 Home Premium 64-bit

Oct 14 2012, 6:48am Anchor

crash while radiation hazard :/ no crash report

Reply to Thread
click to sign in and post

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.