The long awaited Shattered Worlds Freelancer mod has been released. A talented DevTeam from over 6 different Freelancer communities have gathered to work on this ambitious project. Collectively, the team combined modding knowledge and lessons learned from numerous mods/servers, they picked the best concepts from other mods; which were implemented, improved and further expanded. The entire game has been overhauled from the ground up to create a cutting edge balance scheme. The DevTeam also added hundreds of weapons/equipment items, and many new ships, with over 160 individual craft at present, many of which are exclusive to the mod. The end result is one of the most balanced and highest quality Freelancer modifications ever conceived. If you are a new player or an old player tired of normal Freelancer mods, Shattered Worlds has something for you. Come, try it for yourself. When you undock, you will see the next evolution of Freelancer!

Post download Report content SW:WT Freelancer SP Campaign Compatable Client
Full Version
Nov 30th, 2011
188.27mb (197,414,375 bytes)
2,880 (2 today)
Embed Button
Download now

ATTENTION: The original file that wasn't working with FLMM has been replaced with a compatible one. --- 26-5-13 --- - A small patch has occurred to the Mission 8 file to fix the issue of the weapons platforms killing Tekagi's Transport. ------ With the advent of SW:WT 1.6 client the SW mod has ceased to be compatible with Freelancer's Single Player Campaign. The SW admin team still wants to offer Single Player to everyone who loves our work. This mod has been converted from previous versions of SW and is compatible with the Single Player Campaign of Freelancer specifically for enjoying the storyline with the new ship and weapon systems of the SW mod. It is not compatible with the SW:WT server.

Preview Image
SW:WT Freelancer SP Campaign Compatable Client
Post comment Comments
ludimilojko Dec 10 2011 says:

not work m8

+4 votes     reply to comment
StarLion Dec 24 2011 says:

The central directory was not found in the archive.... please, can we have a new file?

Thanks a lot!

Merry christmas and best wishes for the new year


+3 votes     reply to comment
Reactorcore Dec 28 2011 says:

This does not work guys. : (

It says "The central directory was not found in the archive" when attempting to install.

+4 votes     reply to comment
CorporalHicks Dec 28 2011 says:

Rename the file to .rar Then extract the folder to your Freelancer Mod Manager's Mod folder and you will get it to work :)

0 votes     reply to comment
lastgateguard Feb 23 2012 says:

I tried to do that CorporalHicks but it didn't work. it gets about half way to activating the mod and fails. Oh well guess ill just play freelancer without mods. It seems most of the mods i try fail.

+3 votes     reply to comment
tulai Jan 9 2013 replied:

It works, but the mod will appear like version 1.5 on FLMM

+2 votes     reply to comment
tulai Jan 9 2013 replied:

It stopped working!? Well...

+2 votes     reply to comment
Szasz Jan 23 2013 says:

In what does this differ from eg. the 1.64 multiplayer version? I know that the button shows some "non-compatible" label but it is possible to click on it and the campaign with all cutscenes and stuff is working. Just the regular ships are swapped with the multiplayer ones.

+2 votes     reply to comment
reboare Author
reboare Mar 2 2013 says:

For future reference a new version of this client has indeed been uploaded and functions perfectly with FLMM.

+2 votes   reply to comment
SeanEBola Aug 23 2013 says:

If this is the SP version only, it still isn't working still.

It says "The central directory was not found in the archive" when attempting to install.

Clicking on it in mod manager.

+1 vote     reply to comment
reboare Author
reboare Sep 23 2013 says:

I thought I'd fixed the 'central directory' issue but apparently not. Until I figure out why it's still not working you'll have to extract the mod as a .zip or .rar and paste them over your clean install manually.

+1 vote   reply to comment
reboare Author
reboare Sep 23 2013 replied:

This client was also made with/designed for FLMM v1.3, because we found it to be the most stable/friendly. You might also want to try using that version of FLMM.

+1 vote   reply to comment
Post a comment

You are not logged in, your comment will be anonymous unless you join the community. Or sign in with your social account:

Send Message
Release date
Released 2008
Mod watch
Start tracking
MD5 Hash
Related Games
Freelancer Futuristic Sim
Related Groups
Shattered Worlds Development
Shattered Worlds Development Developer & Publisher with 9 members