An expansion/overhaul mod of epic proportions, with entirely rebalanced gameplay, expanded factions, new gametypes, graphical overhauls, and five new factions; stealth-based Confederate Revolutionaries, tower defense-inspired Atomic Kingdom of China, economy-focused Mediterranean Syndicate, DotA-esque Order of the Talon and spammy Electrical Protectorate.

Forum Thread
by member
  Posts  
How to install .. (Mods : Red Alert 3 Paradox : Forum : Suggestions and Questions : How to install ..) Locked
Thread Options 1 2
Oct 2 2011, 2:21pm Anchor

thanks I- I mean my friend solved the problem by tinkering with the game a little bit but he's really thankful for all the help everybodies given him :)

Edited by: SonoftheRepublic

--

Lets have faith that right makes might; and in that faith let
us, to the end, dare to do our duty as we understand it.
Abraham Lincoln

Jul 5 2012, 10:17pm Anchor

Question: Using the STEAM version of the game (no Uprising expansion, is that required?) I made a new shortcut with the -ui tag after the target. I can access the launcher screen and it does display Paradox Mod 9.21.1. I click the mod, double click it, or click "Launch Game" and the splash screen comes up. Then... nothing appears to happen and the game doesn't launch.

Any idea what the problem is? Thanks, this mod does look like it may redeem RA3.

EDIT: Nevermind, I took a break, closed out STEAM and Desura, and came back to try it one last time later and it WORKED.

Edited by: James009

Dec 17 2012, 4:11pm Anchor

I am also having problems with my game. My launcher menu is missing the deauthorize button. It had it before, and my replay browser has no tabs to click. There are no patches available for download, and I am well and truly stumped as to what is wrong. Can someone help me?

Edited by: buddyh

May 1 2013, 2:24pm Anchor

I have the Steam version and EA or Valve decided to be a bunch of dicks and not add Red Alert 3 CONTROL center when you start the game so yeah for IT IS that hard and i would really like if you could post a video on how to install the damn thing

NVM i manage to get it to work thanks to comrade GriffinZ comment.Thank you great comrade and may your always be blessed with lots and lots of loyal communist puppies

May 18 2013, 2:08pm Anchor

Any fixes for those who only have the steam llauncher and not the normal game UI / launcher

May 31 2013, 3:35pm Anchor

Is there a way to force update the game? I think my problem is that it was updated, but then I uninstalled it. I then reinstalled it later, and it was at an earlier version. When I clicked update, it said there were no updates available. So, is there a way to force update it, or manually update it?

Jun 3 2013, 8:18pm Anchor

The game should ask you to update when you try to get online by clicking the red star at the top right.

--

blah

Jun 7 2013, 3:16pm Anchor

Every time I try that it says there are no patches available for download. Is there a way to get around this problem?

Jul 4 2013, 9:58am Anchor

Okay, here's something to chew on. I want to install Paradox but I have the Origin Download Edition; thus, no control panel, no game browser, no nothing.

What should I do? I already tried placing it in Documents/Red Alert 3/Mods/Paradox, but as far as I can tell it had no result.

Reply to Thread
click to sign in and post

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.