The L.U.R.K. team wants to provide the best possible experience from Stalker: Shadow of Chernobyl, we don't plan to skew the scope of this game, because I, like many others, fell in love with the game because of the story, the realistic gameplay, and the atmosphere. I plan to preserve and improve on that concept to the best of my abilities, and our team has vowed to do so as well. Which is why we took it upon ourselves to provide that experience. We want to fulfill a niche that's otherwise unfulfilled in the modding community. We want to bring as many features to Stalker without damaging or changing the original theme of the game. While improving upon that concept with features that were dropped off the development cycle from GSC, such as stealth AI, and a strong foundation for balance, as well as dynamic A-Life, and an unprecedented visual presentation that no other Stalker Overhaul can touch.

Forum Thread
by member
  Posts  
Bug Report Thread (Mods : L.U.R.K. : Forum : Questions : Bug Report Thread) Post Reply
Thread Options 1 ... 5 6 7 8 9 10 11 ... 24
Oct 2 2009, 2:53pm Anchor

Has the MP5 inventory icon bug been fixed yet? The suppressor and scope attachments are way off.

Also, don't you think it's a bit too cheap compared to the other guns?

Oct 2 2009, 2:58pm Anchor

I have the Steam version of STALKER: SoC, and I assume Steam auto-patches it to the latest version.

I downloaded the latest version of the mod and installed it using the mod manager. Picking the LURK (blahblah) option for all installation questions since I didn't look up what any of them meant... Anyways. After installation of the mod (From the .rar file, I should mention.) whenever Try to start the game, my comp'll start loading, and the small rectangular STALKER picture will show up at the center of my screen, go away.... And then that's it. Happens every time.

Any idears?

EDIT: (Makes a thread of the same question due to impatience.)

Edited by: Maelthorn

Daemonion
Daemonion Mountain Man
Oct 2 2009, 2:59pm Anchor
CannonFoddered wrote:Hi. I effin loved this mod until a serious problem cropped up which is hacking me off. It runs amazingly until this happens.

I started playing from the beginning and when i first got to the DUTY base i had no problem. However after going to the labs and returning to DUTY the sh*t hits the fan. When the level loads, i have no problem however as soon as i get to the ditch (where the spike and dog kebabs are :-) ) and step onto the planks of wood that lead to the camp the framerate drops rediculously to 2fps. Its like a flick book in slo mo. :(

I have a fairly powerful machine (stats to follow) and have tried running it with everything on minimum and this still does not solve it. When i get back to the outskirts of the camp i.e. the bridge or the other side of the camp leading to the railway yard, eventually the problem clears and it's "off we go again"

Does anybody have any idea at all what might be causing this. Could it be a memory leak or something and is it fixable. ???

Parts:
Windows Vista™ Home Premium (6.0, Build 6002) Service Pack 2 (64-bit)
Intel Core 2 Quad @ 2.33 (Q8200)
NVIDIA GeForce GTX 260 - DirectX 10
Display Memory: 2670 MB
Dedicated Memory: 879 MB
4Gb of Decent ram


Hate to be the one to break it to you, but this issue has been talked about quite a bit. You started a game with 0.9b (most likely), and installed a patch that required a new game to fix the FPS issue at Bar.

If you look through the thread, you will see that me and another member documented what causes this FPS drop. It is only fixed by starting a new game, or following our directions that we left. on page 3 or 4 or 5. Good luck!

r4b
r4b
Oct 2 2009, 3:23pm Anchor

Daemonion, you seem to have missed 'when i first got to the DUTY base i had no problem. However after going to the labs and returning to DUTY the sh*t hits the fan '
He has already been to the bar once, so the crazy gun spawning isn't the problem. I have found that in a lot of the FPS drops, there is an error message about DetailPathManager failing. I believe this has something to do with spawns.

I mentioned that I had an FPS drop in the bandit camp. I reloaded a previous save and approached the camp from a different angle. I was attacked by a pseudogiant. After I killed it I experienced no FPS drop at all in the camp. I feel it is spawns like these that may be causing problems. Just my two cents

Oct 2 2009, 5:11pm Anchor

I know that this is the bug thread, but:

This mod (IMO) has the best gunfights and weapon balancing since the REDUX mod way back.  It feels very balanced. 

The best gunfights I've ever experienced in a game, period.

Oct 2 2009, 5:25pm Anchor

i can't hand in any of my orginal trader quests all he says is: "Jobs done... and heres the reward" and i recieve no reward or job completion confirmation.

Oct 2 2009, 8:05pm Anchor

I have a bug here.First of all let me start by saying this is a great mod and that I probably will never need another mod for STALKER after this but...My games will not save, no matter what I do. I quicksave, it says that its saved, but when I got to load it, there's nothing there, and when I "Load last save", it boots me back to the game, no menu.This happens with Esc+Saves and Quicksaves..
Any help? :)

Oct 2 2009, 8:39pm Anchor

I can't attach the Leupold scope to any of the M16 rifles and the F2000 doesn't accept the 5.56mm suppressor.
The AUG A1 scope still doesn't work properly.
The suppressor is blocking the Glock 18C's sights.

Daemonion
Daemonion Mountain Man
Oct 2 2009, 9:04pm Anchor
r4b wrote:Daemonion, you seem to have missed 'when i first got to the DUTY base i had no problem. However after going to the labs and returning to DUTY the sh*t hits the fan'

Ha, I even missed the emphasis on DUTY base. Thanks for pointing that out.

I'm sorry to say, CannonFoddered, but I have no experience with this issue and don't think I can be of help to you :(

Oct 2 2009, 9:50pm Anchor

On the FPS drop, I'm experiencing a slight one too, however it's not at all tied with massive amounts of weapons.

I'm not sure what's causing it at the moment, but I have a feeling it'll be figured out before long.

edit: For me it only occurs around the entrance to the bar. The place where the Duty guards are keeping the dogs from entering. Most of the rest of the bar is fine.

Edited by: Ghost783

Oct 3 2009, 12:23am Anchor

After manually installing the patch and following all installation instructions, I can get through the menu and the loading screen for both my saved game and a new game. Though when it finishes loading, it just closes out of the game.

Once again I am playing through Steam.

Oct 3 2009, 2:26am Anchor

I have an interesting... well, I assume that it's a bug. For some reason, I am neutral with the bandits. I first noticed it after joining Freedom. The bandits that I encountered while returning from Yantar yellow in my binoculars. I even spoke to one and have included a link to the screenshot below. Later on in Garbage, I ran into a bandit on the ground. Usually, these wounded neutrals would ask for a medkit, well, this bandit gave me a CTD. I can only assume that the game was calling for a script that wasn't present, as one isn't supposed to go up and talk to bandits.

"
FATAL ERROR
 
[error]Expression    : !phrase_dialog->m_PhraseVector.empty()
[error]Function      : CPhraseDialog::SayPhrase
[error]File          : E:\stalker\sources\trunk\xr_3da\xrGame\PhraseDialog.cpp
[error]Line          : 140
[error]Description   : No available phrase to say, dialog[dm_hello_dialog]
"

Imgur.com

Oct 3 2009, 4:21am Anchor
Daemonion wrote:
[db@ wrote:Metzger]I downloaded the V0.9 last Week and the RC-Patch V1.0.1 and made a new shortcut on my desktop with the -noprefetch parameter like the shown screenshot.
The Result was a bugTrap.
Yesterday I downloades the Patch to Version 1.0.5.5.2 and got the same result

The "Installation Instructions.txt" says: "2. Patch the game to 1.0005" but I've the latest patch V1.0006 installed.
There is no notice in the Instructions that I've to downgrade (Reinstall) to Version 1.0.0.0.5

Is the installed patch V1.0.0.0.6 the Problem or will I do other things because I'm using Vista64 with 8GB RAM and two GF8800GTX in SLi Mode?


The instructions say to use 1.0005.

Uninstall, reinstall, patch to 1.0005, install LURK 0.9 part 1, then part 2, then RC 1.0552 patch.

Thank you for your assistance, but I uninstalled Stalker - SoC, installed it to another location, patched it to Version 10005 and installed LURK 0.9 part 1, then part 2, then RC 1.0552 patch.

The result is the same - a bugtrap :(

Oct 3 2009, 5:12am Anchor

I'm getting mad lag in the arena. No where else really. I mean, except where you'd expect it in the Bar and near the Freedom base. But this is choppy lag rather than stall out lag.

Not sure if it's just pushing my machine or what, but the half of the arena that the opponents start in doesn't lag my game a bit. So I try to sneak over there and fight from that side, but it leaves me with maybe a third of the arena where I can fight from.

Oct 3 2009, 5:47am Anchor
Flamingwoks wrote:i can't hand in any of my orginal trader quests all he says is: "Jobs done... and heres the reward" and i recieve no reward or job completion confirmation.

I got that too, and I found a fix to it.
Take a look at your questlog, I think it will be one of the monster part retrieval quests.
I always stick unneeded stuff to that blue box in the Bar, including unneeded artifacts and monster parts, just for these quests.
If you pick up the quest item, the game marks the quest objective as done.
But if you then put the item in a box somewhere, it still thinks you still have it with you, so the game will try to remove the item and complete the quest, but fails.
Find what quest it is, and get the item again.
Atleast, that was the problem for me.

Oct 3 2009, 11:28am Anchor

I've done a bit more digging around in the .ltx files and it seems to be that the trader is always offering [supplies_start] rather than [supplies_after_darkvalley] or [supplies_after_brain] even when these conditions should have been met. This suggests a problem with another file or script, not with the trader .ltx files (I suspect that with the 0.9 files I was getting [supplies_start] as well, which is significantly better than 1.0552 [supplies_start] so I assumed that it had fixed it. Will double check this now. EDIT: Confirmed.)

Can anyone confirm that with 1.0552 they are getting good items from the barman after Dark Valley or the Brain Scorcher? If it is just me rather than a problem with LURK I will try reinstalling the mod.

Edited by: NoodleMeister

Oct 3 2009, 1:50pm Anchor

FATAL ERROR
 
[error]Expression    : hFile>0
[error]Function      : FileDownload
[error]File          : E:\stalker\sources\trunk\xrCore\FS.cpp
[error]Line          : 106
[error]Description   : l:\adam\games\steam\steamapps\common\stalker shadow of chernobyl\gamedata\config\
 

I have reinstalled the game, reinstalled and redownloaded the mod, and I still get this error. I have gotten this error ever since 1.5 came out. Since I appear to be the only one getting this, I understand that it may not be that important to you Holden, but I really would like to play

r4b
r4b
Oct 3 2009, 2:35pm Anchor

NoodleMeister. I have that problem too. Just finished X16, and skinflint offers me FN2000s and G36s, but barkeeps inventory is the same as always. BTW, the G36E's scope is impossible to see through.

On another note, since Holden changed every suit that isn't sold by traders into a leather jacket, returning Ghost's jacket to Sakharov is messed up. I have returned it to him but he didn't give me a SP99M and the task has disappeared ;_;. There are a few 'find the jacket' quests but since they are all leather jackets, I can't tell them apart so I don't know which ones I can trade.

Oct 3 2009, 2:52pm Anchor

BUG IS FIXED :D

Alright this is really simple.

To fix the bug where traders do not offer the correct items you just need to change the fourth line in the trader's .ltx file. These are in gamedata/config/misc and the ones you need to edit are:
- trader_barman.ltx
- trader_dolg.ltx

For the barman change the fourth line to:

code:
buy_supplies = {+yan_labx16_switcher_primary_off} supplies_after_brain, {+bar_darklab_document_done} supplies_after_darkvalley, supplies_start

For the Duty trader change the fourth line to:

code:
buy_supplies = {+bar_svoboda_rg6_done} supplies_after_rg6, supplies_start

and this should fix the problem. The problem was that supplies_start was first and this just screwed things up. Traders like Skinflint, Sidrovich and the Scientist had supplies_start at the end of the line and so they worked. These parameters for new equipment to be sold need to be in reverse order of completion.

Oct 3 2009, 4:47pm Anchor

My problem is that stalker sometimes freezes a lot, but it ends in 1- 2 seconds. Especially in Garbage, Agroprom, Army Warehouses and Bar.
So I look my console and it says:
(In red)
"Invalid ogg-comment version, file:  d:\games\s.t.a.l.k.e.r. - shadow of chernobyl\s.t.a.l.k.e.r. - shadow of chernobyl \gamedata\sounds\characters_voice\human_03 \freedom\music\harmonica_2.ogg"
etc.
Also:
"! auto-generated bump map: arsenal_mod\sg552_d1_bump#"
etc.

I remember having these kind of problems also in other mods.
I have Vista x32 and I run Stalker in Admin mode.

Oct 3 2009, 6:27pm Anchor

Hey all, got a problem with the arena. Every time I'm issued armor for a fight, its just a leather jacket. The arena master will tell me its something entirely different, like a Wind of Freedom Suit, or a Berill, and all I get is a Leather Jacket. Is this just me or what?

Oct 3 2009, 7:45pm Anchor
SackSeagull wrote:My problem is that stalker sometimes freezes a lot, but it ends in 1- 2 seconds. Especially in Garbage, Agroprom, Army Warehouses and Bar.
So I look my console and it says:
(In red)
"Invalid ogg-comment version, file:  d:\games\s.t.a.l.k.e.r. - shadow of chernobyl\s.t.a.l.k.e.r. - shadow of chernobyl \gamedata\sounds\characters_voice\human_03 \freedom\music\harmonica_2.ogg"
etc.
Also:
"! auto-generated bump map: arsenal_mod\sg552_d1_bump#"
etc.

I hear that the ogg-comment problem is rather easy to fix but you're going to need the SDK and the original sound files so we may have to wait for the devs to fix it themselves. I don't think there's anything that could be done about the auto-generated bump map thing though.

Oct 3 2009, 9:41pm Anchor

-Bug related to one of Freedom members patrolling in Freedom base, near the small "camp".
An interesting chat commences with the guy, but on the final line before the dialogue closes, the dialogue option is bugged -- it reads something like "mil_base_dialogue" or something roughly along those lines. Basically, I doubt its the proper response.

I cant remember the name of the guy, but he says "come here, lets have a little chat". He ISNT the guy patrolling by the entrance who gives you the "warning" when first entering the freedom base, and it isnt Max either.

-OTs-14 Groza model bugged. Grenade model "hovers" next to weapon model.

-Background music which plays from tower in Bar area is heard too clearly when inside the actual 100 rads bar. Both the 100 rads music + Bar area background music clash because of this. Not a huge issue, but somewhat uncomfortable on the ears.

-Bandits spawn right where Fox and, more importantly, Guide are located over in Cordon (by the large destroyed bridge). Inevitably, unless one goes really out of their way (ie: making sure Guide survives the spawning bandit attack everytime you pass by), Guide will almost certainly die before you meet him later on in the story.
I havent progressed far enough to see how this will affect things, but I imagine this is a bug.

-Background music doesnt play where the first trader is located.

-Stalkers seem to randomly get severely injured over in the Bar area. Often when I pass through the Bar area, over by one of the camp fires, theyrell be a Stalker needing a medkit.

Oct 3 2009, 9:44pm Anchor

I've noticed a bug when using the sleeping bag. What happens is I use the sleeping bag for about 12 hours, so the clock goes from 21 hours to 9 hours, but the weather and sky stays the same. For example, I would go to bed at 21 and the weather would be stormy and rainy, and wake up at nine, and the weather would still be the same. Not only that, but at nine in the morning the sky would be filled with stars. Sleeping til later in the day (14 hours, for example) didn't change anything, and the sky stayed starry, and the weather rainy. When I quicksaved, and reloaded, however, the weather adjusted itself - the rain stopped and the sun was out.

Oct 3 2009, 9:56pm Anchor
NoodleMeister wrote:this should fix the problem. The problem was that supplies_start was first and this just screwed things up. Traders like Skinflint, Sidrovich and the Scientist had supplies_start at the end of the line and so they worked. These parameters for new equipment to be sold need to be in reverse order of completion.

Well spotted, thanks!

SuicideDivision wrote:-OTs-14 Groza model bugged. Grenade model "hovers" next to weapon model.

I suspect that issue is even present in vanilla, but it's off-camera because of the iron sight zoom in vanilla. There's also another bug with that weapon. When you switch either to or from the integral grenade launcher (I forget which) the grenade inside the launcher clips through for a moment. I checked and that problem is definitely present in vanilla. We're looking into porting a fixed model for this weapon from the Clear Sky version of Arsenal.

I've noted all of your other points, too. Thanks for the reports, everybody!

Edited by: MattyDienhoff

Reply to Thread
click to sign in and post

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.