The L.U.R.K. team wants to provide the best possible experience from Stalker: Shadow of Chernobyl, we don't plan to skew the scope of this game, because I, like many others, fell in love with the game because of the story, the realistic gameplay, and the atmosphere. I plan to preserve and improve on that concept to the best of my abilities, and our team has vowed to do so as well. Which is why we took it upon ourselves to provide that experience. We want to fulfill a niche that's otherwise unfulfilled in the modding community. We want to bring as many features to Stalker without damaging or changing the original theme of the game. While improving upon that concept with features that were dropped off the development cycle from GSC, such as stealth AI, and a strong foundation for balance, as well as dynamic A-Life, and an unprecedented visual presentation that no other Stalker Overhaul can touch.

Forum Thread
by member
  Posts  
Bug Report Thread (Mods : L.U.R.K. : Forum : Questions : Bug Report Thread) Locked
Thread Options 1 ... 4 5 6 7 8 9 10 ... 24
Oct 1 2009, 1:42am Anchor

Something small here, but the mosin nagant doesnt accept the scope it says it can in the description. Could you possibly include a PU scope with it? And another thing, its probably intentional but the vintorez doesnt have a scope on it, it shows it for the inventory pic but not on the actual rifle, and when you put a scope on it overlaps the other scope.

Oct 1 2009, 4:09am Anchor

I downloaded the V0.9 last Week and the RC-Patch V1.0.1 and made a new shortcut on my desktop with the -noprefetch parameter like the shown screenshot.
The Result was a bugTrap.
Yesterday I downloades the Patch to Version 1.0.5.5.2 and got the same result

The "Installation Instructions.txt" says: "2. Patch the game to 1.0005" but I've the latest patch V1.0006 installed.
There is no notice in the Instructions that I've to downgrade (Reinstall) to Version 1.0.0.0.5

Is the installed patch V1.0.0.0.6 the Problem or will I do other things because I'm using Vista64 with 8GB RAM and two GF8800GTX in SLi Mode?

Daemonion
Daemonion Mountain Man
Oct 1 2009, 4:32am Anchor
[db@ wrote:Metzger]I downloaded the V0.9 last Week and the RC-Patch V1.0.1 and made a new shortcut on my desktop with the -noprefetch parameter like the shown screenshot.
The Result was a bugTrap.
Yesterday I downloades the Patch to Version 1.0.5.5.2 and got the same result

The "Installation Instructions.txt" says: "2. Patch the game to 1.0005" but I've the latest patch V1.0006 installed.
There is no notice in the Instructions that I've to downgrade (Reinstall) to Version 1.0.0.0.5

Is the installed patch V1.0.0.0.6 the Problem or will I do other things because I'm using Vista64 with 8GB RAM and two GF8800GTX in SLi Mode?


The instructions say to use 1.0005.

Uninstall, reinstall, patch to 1.0005, install LURK 0.9 part 1, then part 2, then RC 1.0552 patch.

Oct 1 2009, 6:53am Anchor

For some reason I never get hungry...is this a bug or something put in deliberately?

r4b
r4b
Oct 1 2009, 8:47am Anchor

I am getting a bizarre issue I've not noticed anyone else mention. At seemingly random points in the game, my screen will suddenly turn bright yellow:

The FPS seems to plummet as well, although I can't see anything I can still open the inventory and quicksave. If I exit the game and load ANY save, the game runs normal except weapon models (unless in ironsights) become invisible. Quitting to Windows and restarting resolves this.

I can find no common cause or see related errors in either the console or log, but if this were a gfx card issue as opposed to LURK isue, surely I would notice problems in other graphic intensive games (Like Fallout 3, Far Cry 2 or Crysis) but I don't.

Edited by: r4b

Oct 1 2009, 9:27am Anchor

Trader bug as of 1.0552:

It seems that the sell conditions to offer the player better items aren't being met. I've just finished Red Forest and the Barkeep still only sells M1891, Saiga, PPSH and sometimes an SVD.

I'll be starting a new game to test this with the other traders, and to make sure it's a problem with the traders rather than my save game.

EDIT: This bug seems to have occurred in one of the updates, as when I use the trader .ltx files from LURK version 0.9 some new weapons are sold. I'll check between 0.9 and 1.0552 files so see what the difference is.

EDIT2: Using trader .ltx files from 0.9 is not fine, it brings back the gun-drop bug. Looks like 1.04 has the same problem (no new guns) as 1.0552, and 1.04 is the earliest RC I have.

Edited by: NoodleMeister

Oct 1 2009, 1:17pm Anchor
MattyDienhoff wrote:That's a good idea, but chances are it'd quickly get hopelessly outdated. I'm having enough trouble just keeping my own internal buglist current.

So in that case, wouldn't it be easier to have one centralized buglist that everyone can view/edit/add to? :)

Oct 1 2009, 5:15pm Anchor

I just keep merging updated patches with the one I already have to make sure nothing valuable is lost, this way I can edit the trader lists for example, to my own likings.

Just like certain weapon flaws (AK being weaker than its 74 counter part), these are thus simply eliminated in less than 10 minutes work.

Oct 1 2009, 5:17pm Anchor

The body-part dropped off the burer has no description. The MP5 has no description.

r4b
r4b
Oct 1 2009, 5:30pm Anchor

Does anyone read these? I certainly hope so, because I keep running into bugs.
Was clearing out the bloodsuckers in the village at Army Warehouses, and I went into the basement with the grenade launcher. CTD

FATAL ERROR

[error]Expression : assertion failed
[error]Function : CSafeFixedRotationState::create
[error]File : e:\stalker\sources\trunk\xr_3da\xrgame\phvalidevalues.h
[error]Line : 81
[error]Description : dBodyStateValide(b)

Oct 1 2009, 9:07pm Anchor

Been getting a wierd bug since I downloaded and installed 1.05, all of the armor in the world, like the Merc suit in the rookie village has turned into a leather jacket. The STALKER Suit in Strelok's hideout turned into a leather jacket. The Barkeep didn't give me a STALKER Suit for bringing him the first set of documents. The STALKER Suit in the pipe in the factory turned into a leather jacket. Not to sound rude, but HOW THE HELL AM I SUPPOSED TO SURVIVE WITH A LEATHER JACKET FOR THIS LONG?! I mean, I have the money to go and BUY a merc suit, but I shouldn't have to! I've had 1 chance to get a merc suit, and 3 chances to a STALKER Suit, FOR FREE! Is this just me or what?

Oct 1 2009, 9:07pm Anchor
NoodleMeister wrote:It seems that the sell conditions to offer the player better items aren't being met. I've just finished Red Forest and the Barkeep still only sells M1891, Saiga, PPSH and sometimes an SVD.

He should be stocking many different weapons from the start, including at least a few pistols. Of course, his stock is slightly different each time, but he should always have a wide selection of guns. Next time you're there, can take a couple of screenshots of his stock? Also, check the console and look for a large white error message saying something like 'can't update trade_barman'.

NoodleMeister wrote:EDIT2: Using trader .ltx files from 0.9 is not fine, it brings back the gun-drop bug. Looks like 1.04 has the same problem (no new guns) as 1.0552, and 1.04 is the earliest RC I have.

Yes, the traders were revamped in one of the first patches.

AgentJR wrote:So in that case, wouldn't it be easier to have one centralized buglist that everyone can view/edit/add to? :)

That's what I was thinking, but I can't see how we could do that in a forum system, where only post authors and moderators can edit. If only there was a wiki on which you could reserve a few pages for a specific purpose? That'd be useful for stuff like this.

hina9888 wrote:The body-part dropped off the burer has no description. The MP5 has no description.

The latter has been fixed in the current build, and the former will be soon.

r4b wrote:Does anyone read these? I certainly hope so, because I keep running into bugs.
Was clearing out the bloodsuckers in the village at Army Warehouses, and I went into the basement with the grenade launcher. CTD

FATAL ERROR

[error]Expression : assertion failed
[error]Function : CSafeFixedRotationState::create
[error]File : e:\stalker\sources\trunk\xr_3da\xrgame\phvalidevalues.h
[error]Line : 81
[error]Description : dBodyStateValide(b)


Yes. :)

I have no idea what's causing that, I'll ask around to see if this is a known bug. Which version are you running?

SimplyStealth wrote:Been getting a wierd bug since I downloaded and installed 1.05, all of the armor in the world, like the Merc suit in the rookie village has turned into a leather jacket. The STALKER Suit in Strelok's hideout turned into a leather jacket. The Barkeep didn't give me a STALKER Suit for bringing him the first set of documents. The STALKER Suit in the pipe in the factory turned into a leather jacket. Not to sound rude, but HOW THE HELL AM I SUPPOSED TO SURVIVE WITH A LEATHER JACKET FOR THIS LONG?! I mean, I have the money to go and BUY a merc suit, but I shouldn't have to! I've had 1 chance to get a merc suit, and 3 chances to a STALKER Suit, FOR FREE! Is this just me or what?

I think that change was intentional so good suits could only be purchased. It seems to be poorly implemented though, because I've heard that the suits you find lying around look like good suits, but are actually leather jackets once you pick them up, is that so?

dave_5430 wrote:Just like certain weapon flaws (AK being weaker than its 74 counter part), these are thus simply eliminated in less than 10 minutes work.

There are a lot of issues with the weapon ballistics and configuration. We're going to re-do that stuff from scratch in the near future.

Edited by: MattyDienhoff

Oct 1 2009, 9:51pm Anchor

Actually, yeah, the suits you find lying around look like what they're supposed to be, but when the name appears and you pick them up, they turn out to be Leather Jackets. Also, I've noticed that some of the jackets sell for 299 Ru to a trader, while others sell for 999 to that SAME trader.

Edited by: Sabine

Oct 1 2009, 10:01pm Anchor

some of the side missions are messed up. it looks to be because of the changed spawn points. both "eliminate the bandits in the garbage" missions (one from sidorovich and the other from the bar keep) and the "eliminate the zombie" mission from voronin have loners spawned instead of the intended targets. despite this the camp elimination icon is still on the mini-map. also, i have had side missions spring up on me spontaneously. the 2 that come to mind are "kill the lair of the bloodsucker" while clearing the bandit camp to get borov's key and "eliminate the bandits" while in the apropom underground looking for strelok's stash. these are the only ones that i have seen so far, but i am not very far in the game. these issues are really an annoyance, but some of these missions are non-completable and i would like to be able to finish them for the rewards....

Oct 1 2009, 11:42pm Anchor
MattyDienhoff wrote:He should be stocking many different weapons from the start, including at least a few pistols. Of course, his stock is slightly different each time, but he should always have a wide selection of guns. Next time you're there, can take a couple of screenshots of his stock? Also, check the console and look for a large white error message saying something like 'can't update trade_barman'.


Here is a screenshot of his wares after Red Forest and half of Pripyat has been cleared. Using quick-save and quick-load produces very little variation: sometimes the SVD is not there but that is all.

Here are some screenshots from the console, not got the exact line you asked for but hopefully one of these can tell you something: [1] [2] [3]

Oct 2 2009, 12:25am Anchor

Got a new bug here it seems, pretty big one. I searched the thread but didn't find anything:

After taking care of the snipers for Duty at (I believe) the first Freedom base, where they use Dynamite to bust in, I left after killing basically everything in sight. I'm just outside the walls of the base now with various anomalies around, and I quicksaved. The game crashes to desktop a few seconds later (the first I've gotten so far with LURK I might add). I get back in, walk a few steps, CTD. This happens 5 or 6 times and now the game won't even load at all. It gets to CLIENT: Synchronizing and then just stops. When I kill the process the memory usage for it is through the roof. HALP.

Oct 2 2009, 1:32am Anchor

Another small thing, ammo weights seem to be drastically off as well as weight for some guns.

r4b
r4b
Oct 2 2009, 8:12am Anchor

@MattyDienhoff

I'm running STALKER 1.005 with LURK patched up to 1.552

Oct 2 2009, 11:23am Anchor

Hi. I effin loved this mod until a serious problem cropped up which is hacking me off. It runs amazingly until this happens.

I started playing from the beginning and when i first got to the DUTY base i had no problem. However after going to the labs and returning to DUTY the sh*t hits the fan. When the level loads, i have no problem however as soon as i get to the ditch (where the spike and dog kebabs are :-) ) and step onto the planks of wood that lead to the camp the framerate drops rediculously to 2fps. Its like a flick book in slo mo. :(

I have a fairly powerful machine (stats to follow) and have tried running it with everything on minimum and this still does not solve it. When i get back to the outskirts of the camp i.e. the bridge or the other side of the camp leading to the railway yard, eventually the problem clears and it's "off we go again"

Does anybody have any idea at all what might be causing this. Could it be a memory leak or something and is it fixable. ???

Parts:
Windows Vista™ Home Premium (6.0, Build 6002) Service Pack 2 (64-bit)
Intel Core 2 Quad @ 2.33 (Q8200)
NVIDIA GeForce GTX 260 - DirectX 10
Display Memory: 2670 MB
Dedicated Memory: 879 MB
4Gb of Decent ram

Oct 2 2009, 11:35am Anchor
NoodleMeister wrote:
Here is a screenshot of his wares after Red Forest and half of Pripyat has been cleared. Using quick-save and quick-load produces very little variation: sometimes the SVD is not there but that is all.

I had almost the exact same set of wares the first time I got to the Bar, with the exception that he had no scopes, and only one silencer.

Wouldn't it make more sense for him to sell a couple modified guns and a few rare artifacts for obscene prices, than a selection of subpar weapons?

r4b
r4b
Oct 2 2009, 12:10pm Anchor
CannonFoddered wrote:Hi. I effin loved this mod until a serious problem cropped up which is hacking me off. It runs amazingly until this happens.

I started playing from the beginning and when i first got to the DUTY base i had no problem. However after going to the labs and returning to DUTY the sh*t hits the fan. When the level loads, i have no problem however as soon as i get to the ditch (where the spike and dog kebabs are :-) ) and step onto the planks of wood that lead to the camp the framerate drops rediculously to 2fps. Its like a flick book in slo mo. :(

I have a fairly powerful machine (stats to follow) and have tried running it with everything on minimum and this still does not solve it. When i get back to the outskirts of the camp i.e. the bridge or the other side of the camp leading to the railway yard, eventually the problem clears and it's "off we go again"

Does anybody have any idea at all what might be causing this. Could it be a memory leak or something and is it fixable. ???

Parts:
Windows Vista™ Home Premium (6.0, Build 6002) Service Pack 2 (64-bit)
Intel Core 2 Quad @ 2.33 (Q8200)
NVIDIA GeForce GTX 260 - DirectX 10
Display Memory: 2670 MB
Dedicated Memory: 879 MB
4Gb of Decent ram


I feel your pain. I'm raiding the bandit camp in dark valley in the middle of the night, going for stealth. I managed to pick off about 4 of them before my FPS drops to 3. It's freaking impossible now because every frame I manage to see, they have all moved and fired 3 shots at me before I can react. No errors in console or log other than 'Invalid ogg-comment' which I have noticed happens a lot.

Oct 2 2009, 12:32pm Anchor

I did everything the installer said and everything runs fine but I can't save my game. Quicksaving and menu saving both don't work. I'm running it through steam so maybe that's the problem but has anyone else had this happen to them?

Oct 2 2009, 1:15pm Anchor

I've noticed that at the brain scorcher when the mind animals or whatever their called hit you until you have a red brain symbol, then hit you one more time which should kill you, instead I crash.

Oct 2 2009, 1:18pm Anchor
SourMilk wrote:I did everything the installer said and everything runs fine but I can't save my game. Quicksaving and menu saving both don't work. I'm running it through steam so maybe that's the problem but has anyone else had this happen to them?

If your settings aren't being saved either, check your user.ltx file's first line and ensure that it's pointing to a directory that you can write to/exists. Especially if your OS is installed on something other than the C drive.

Oct 2 2009, 1:33pm Anchor
marbai wrote:
SourMilk wrote:I did everything the installer said and everything runs fine but I can't save my game. Quicksaving and menu saving both don't work. I'm running it through steam so maybe that's the problem but has anyone else had this happen to them?

If your settings aren't being saved either, check your user.ltx file's first line and ensure that it's pointing to a directory that you can write to/exists. Especially if your OS is installed on something other than the C drive.



the first line of my user.ltx file is _preset High. and I looked through the entire file and it doesn't show where I'd be saving to. You were right about it not saving my settings though I just don't understand what I need to change to fix it. Thank you for the help though.

Reply to Thread
click to sign in and post

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.