Sins of a Solar Empire is often described as a 4XRTS game, or a game that tried to merge the action and tactics packed gameplay of a Real time strategy game with the deep, complex, empire wide strategy of a 4X turn based game. It's up to debate whether Sins succeeded in this goal, but I think all can agree that of the 4Xs of "explore, expand, exploit, and exterminate", Sins is much more focused on the exterminate than on the others. This mod seeks to give more depth to the other 3Xs of the game by adding additional game elements or refining the existing ones to reward players who give more strategic thought to the non-combat side of the game. Combat will still be the center point of the game, but players will find that the non-combat options available will be much more rewarding. Spying, exploring, sabotage, diplomacy, culture, and economic development have all been added or changed in innovative new ways. Regardless of what you think Sins is, this is the 4XRTS it should have been.

Forum Thread
by member
  Posts  
Styx Desolation Engine research (Mods : Enhanced 4X Mod : Forum : Bugs : Styx Desolation Engine research) Locked
Thread Options
Jul 20 2012, 8:38pm Anchor

Playing as a Advent Loyalist and have everything researched only thing I don't have all of is the artifacts. Captured the planet with the Styx Desolation Engine and then captured the engine and it says the research pre is not done to use it. Am I missing something?
Research it says it needs is "Planetary Organic AI"
Came down to the final battle with the last enemy and it slowed down to a crawl and froze. While slowing down I managed to squeeze off a save. Can't use it though cause each time I load it it just loads frozen. :-/ Finally offed his Titan too! LOL  
Load a save just before that and it gets into the battle and then minidumps. This last opponent is also Advent Loyalist.
 Oh just this mod and 1.31 btw

Edited by: madderoftime

GoaFan77
GoaFan77 Master Modder
Jul 20 2012, 11:22pm Anchor

That is correct. Planetary Organic AI isn't a normal research subject. Its a planetary artifact, the ones you get my exploring a planet. All of those fancy ancient structures' abilities require a different planet artifact to function.

I'm hoping the next patch will help performance a bit, and the Sins forums is full of people trying to come up with ways to get Rebellion to run smoother.

--

Enhanced 4X Mod

Jul 21 2012, 4:53am Anchor

So it is possible then for the artifact to be on a planet other than the one with the ancient structure. Or so it would seem. In that game I have that planet all explored and didn't find it. Good to know. My enemy has my artifact! LOL grrrr!

GoaFan77
GoaFan77 Master Modder
Jul 21 2012, 4:30pm Anchor

Yes, ancient structures and planetary artifacts are spawned completely at random. The correct artifact to power a structure may not even be on the map or vice versa. However, on any map bigger than random medium, on average there will be at least 1 ancient structure with the correct artifact somewhere.

--

Enhanced 4X Mod

Aug 14 2012, 7:32pm Anchor

i dont know why but enhanced 4x mod is minidumping when it shows the E4x title before it shows who made game, This started happening after i downloaded Requiem

GoaFan77
GoaFan77 Master Modder
Aug 15 2012, 1:31am Anchor

Well first of all hijacking a random thread about a totally different issue is probably not the best way to report the issue. Second, are you using Requiem with Enhanced 4X? While I wanted to make the two compatible at one point, E4X has just become a lot bigger and more complicated so that this is no longer feasible. That said, it is possible in the future that Star Wars fans of this mod might get something even better than that.

If you haven't enabled E4X and Requiem together, it sounds like either one mod isn't fully being fully disabled before the other applies, or you somehow got the Requiem files inside the base game files. In the first case, I would try disabling all mods first, restarting and then enabling E4X. If none of that works, try a reinstall, E4X assumes the base game files are fully intact.

--

Enhanced 4X Mod

Aug 18 2012, 11:46am Anchor

Fixed it turns out i deleted the two manifests in the mod folder so i had to reinstall mod

Reply to Thread
click to sign in and post

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.