Sins of a Solar Empire is often described as a 4XRTS game, or a game that tried to merge the action and tactics packed gameplay of a Real time strategy game with the deep, complex, empire wide strategy of a 4X turn based game. It's up to debate whether Sins succeeded in this goal, but I think all can agree that of the 4Xs of "explore, expand, exploit, and exterminate", Sins is much more focused on the exterminate than on the others. This mod seeks to give more depth to the other 3Xs of the game by adding additional game elements or refining the existing ones to reward players who give more strategic thought to the non-combat side of the game. Combat will still be the center point of the game, but players will find that the non-combat options available will be much more rewarding. Spying, exploring, sabotage, diplomacy, culture, and economic development have all been added or changed in innovative new ways. Regardless of what you think Sins is, this is the 4XRTS it should have been.

Forum Thread
by member
  Posts  
Freezing --> MiniDump --> Wrong Checksum (Mods : Enhanced 4X Mod : Forum : Bugs : Freezing --> MiniDump --> Wrong Checksum) Locked
Thread Options
Feb 13 2013, 12:40am Anchor

Alright, here goes.

So I attempted to play a large random map. Worked fine for a few hours, then started freezing disgustingly, non-stop, for intervals of 5-10 seconds every few moments. Restarted repeatedly - didn't help. My GPU was barely being used, and processor cores can't have been said to be straining. While this had never happened before without the mod, I perused these forums and have read that such degradation happens. Okay. Perhaps there were too many mines or trade ships or whatnot at once. So...

(Please note that the Cheksum was correct up to this point)

So I downgraded to a medium sized map. Less than 2 hours in I get this minidump error thing. Again, restarted from an autosave, played for a few minutes, then the minidump happened at the exact same moment as last time. I cannot be sure what the cause was, but some AI Advent had just jumped into one of my (TEC Rebels) planet's gravity well.
Again, I checked this site, to see that there was a hotfix for a common minidump thing.

I downloaded it, was prompted to replace some files in the mod folder, and did so as instructed. Now that I prompt it the checksum is 28526366 - obviously the wrong one.

I reinstalled; same issue. I can't help but feel I am being a retard and doing something completely wrong, but I am now at a loss as for what to do.

GoaFan77
GoaFan77 Master Modder
Feb 13 2013, 6:14pm Anchor

Huh, you don't have any of the minimods enabled right? And you are running Rebellion version 1.1?

--

Enhanced 4X Mod

Feb 14 2013, 12:48am Anchor

I am indeed running 1.1. The checksum was fine prior to replacing the files, and the mod ran, despite - as I mentioned - encountering insane lag/degradation after about half a game on the large map.

I have none of the minimods enabled. Or even downloaded for that matter.

:S

EDIT: just tried reinstalling the mod with patch. Same wrong checksum.

Edited by: Anomandaris

GoaFan77
GoaFan77 Master Modder
Feb 15 2013, 1:10am Anchor

Hmm, Anomandaris, I tried reinstalling the mod myself and I got your checksum, so you're doing the process right. So either I screwed up in writing the checksum or the upload got screwed up somehow.

Can you go into more detail about the freezing you got? I have two saves of some bizarre slow downs that do virtually freeze the game, and both seem to involve Advent Loyalists fleets with Coronata titans. I haven't had a lot of time to look at it though.

--

Enhanced 4X Mod

Feb 15 2013, 6:37pm Anchor

Well this is certainly peculiar.

I found one save where it freezes. About 2 hours and 45 minutes in and either on a medium or large map (8 players), one star. It does essentially freeze the game, it took my titan several minutes to jump from one planet to another (and I'm talking about only transit time, not charging up), due to it freezing ceaselessly for 2-10 second intervals.

The peculiar thing is that there are no enemy ships in sight. I do not really have a fleet to speak of myself. I am playing as HTS, and had destroyed one AI earlier, and am only aware of the planets of two others (hidden by fog). One is VCC and the other Ascended. The Ascended planet is undiscovered and I can only see it because of the culture bar. I do not recall running into their ships other than scouts. I had fought with the VCC but am not doing so at the time of the freezing. The only things going on in my visible part of the map when I load it is a few of my trade ships being in transit. If they AIs have their titans built, I do not recall seeing them.

Conversely, yesterday I played a full vanilla rebellion game that lasted over 8 hours, on a large map, with every faction. At no point did it ever freeze or were any issues encountered. :cry:

Heh, I don't mean to keep bothering you, but with my long-time favorite Distant Stars essentially defunct, yours is the only mod I feel substantially superior to the core game. Sins has been by far my favorite game since vanilla release, and it is difficult to find adequate alternatives.

It is very fun for the time it works, and I would like to add my sincere thanks for your effort.

GoaFan77
GoaFan77 Master Modder
Feb 15 2013, 6:42pm Anchor

Yes, that does sound like the issue I'm trying to track down. Please send me the save that freezes, the more examples I have the easier it will be to track down the cause. Sorry for the confusion about the checksum.

Also, feel free to let me know what you and your fellow Distant Stars refugees might be missing in the request forum. No promises of course, but I do plan on adding a minimod that expands the research like they did. And to be honest its been so long since I've played DS I no longer remember what else it did.

--

Enhanced 4X Mod

Feb 16 2013, 12:41am Anchor

Err, how does one access/send a save, exactly?

Edit: found the saves. theres a savereb and a statsreb file with the same name (??). So how do I send it?

Edited by: Anomandaris

GoaFan77
GoaFan77 Master Modder
Feb 16 2013, 11:38pm Anchor

Yeah, those are the files. Zip them up, and I'd prefer it if you uploaded them to a file sharing site like dropbox or mediafire, and then sent me the link, but if that isn't an option for you I can PM you my email address.

--

Enhanced 4X Mod

Feb 18 2013, 6:53pm Anchor

I PMed you a pair of freezing saves .7z

At this point I can fairly confidently say the freeze is likely to do with advent. I played a large game with only TEC and Vasari factions to the end with full fleets, max research, over one hundred planets - nothing approaching a freeze.

Are you certain it is the Coronata? In one of my freezes I had used that titan for the better part of the game, but it did freeze during a battle-ball between advent loyalists and rebels.

I can attempt playing a large game with only the rebel advent faction, as well as the TEC and Vasari factions, to see if it freezes, if that would help.
If it does not - a game as loyalists without building Coronata? Just holler if you need more data in this regard.

Reply to Thread
click to sign in and post

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.