Savage 2: A Tortured Soul takes the best of the FPS, RTS, and RPG genres and blends them seamlessly into an extremely addictive and complex experience. Anyone who's seen the game in action knows that each match is full of possibilities for epic moments and amazing displays of skill and strategy. Take the reigns as your team's commander from an overhead RTS perspective with superior strategic insight -- or join them on the field from a mixed action RPG and FPS view with a wide array of powerful classes and carve your path to victory.

Forum Thread
by member
  Posts  
Having trouble running under linux? (Games : Savage 2: A Tortured Soul : Forum : Help and techsupport : Having trouble running under linux?) Locked
Thread Options
Jan 13 2012, 5:10pm Anchor

If you are having problems running with linux, try the following:

Right click on Savage 2 in desura -> properties and add: LD_LIBRARY_PATH=".":"$LD_LIBRARY_PATH
to the user launch options.

It is a library issue that can also be corrected by moving the .so files to the libs directory.

Jan 14 2012, 1:49pm Anchor

i did this and it doesnt work.also when i select launch the desura app closes and nothing happens
i  have ubuntu 11.10 btw

Jan 14 2012, 7:22pm Anchor

try: : LD_LIBRARY_PATH=".":"./game"$LD_LIBRARY_PATH

Jan 15 2012, 10:16am Anchor

You can also try it this way:

go to your desura/common/savage2-a-tortured-soul/ and run: savage2.sh LD_LIBRARY_PATH=".":"./game"$LD_LIBRARY_PATH

Mar 3 2012, 1:50pm Anchor

I tried the methods listed above with nothing but a quick flash of black screen and nothing happens.

This is what prints out. x64 Ubuntu 11.10, Radeon HD4850 1GB, 9GB RAM, 2.67GHz i7

code:
warning: The VAD has been replaced by a hack pending a complete rewrite
failed to create drawable
X Error of failed request:  BadDrawable (invalid Pixmap or Window parameter)
  Major opcode of failed request:  55 (X_CreateGC)
  Resource id in failed request:  0x3c00009
  Serial number of failed request:  74
  Current serial number in output stream:  76
 
Mar 14 2012, 9:46pm Anchor

This looks like a video driver issue. Can you confirm your video card type and driver version?

Jul 10 2012, 11:18am Anchor

i have this same problem as for my video card i cant i have no idea  tell you i run Ubuntu 12.04 LTS and when i check out system details under graphics it does say driver: R200 (RV250 4C66) x86/MMX/SSE2 TCL DRI2  if you have a way for me to check my video card tell me and i will post that too

Reply to Thread
click to sign in and post

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.