It is the year 2287, one of the first colony ships sent out by Earth arrives at the planet Maria, in the Epsilon Indi Star System. During its landing sequence, something appears in front of the massive ship that causes it to lose control and crash into the planet. Some of the colonists survive in lifeboats, but what they find is an unforgiving land filled with creatures ready to outlast the visitors from Earth. Now the survivors must explore, gather, build, create, fight, and ultimately, conquer the land.

Forum Thread
by member
  Posts  
suggestion/ Bugs? (Games : Planet Explorers : Forum : Alpha Discussion : suggestion/ Bugs?) Locked
Thread Options 1 2
Jul 3 2012, 11:12am Anchor

First! nice game! relly like it!

suggestions:
* Reg small amount of hp when your in non combat
* Make stuff physical ( so u can't run right through trees and enemies and other stuff
* When you jump you almost loose all speed forward/backward maybe rise it a little.
* Add a "close all windows" button
* hit the same button twice closes the window (hit "TAB" once open EQ and inv, hit "TAB" again close those windows)
* Auto save
* "mission progress" ( if you need to cut 100 wood, you should see like 59/100) in misson window or on the screen somewhere.

And sometimes it is VERY hard to click on trees.. you just stand there and swing your axe :P

Bugs:
*If you just exit a game, and then start a new singel player game. you start where you leaved the last game


(sorry for my bad English)

// DeG

Edited by: D3nn05

Jul 5 2012, 6:07am Anchor

Thanks D3nn05, several of the suggestions you mentioned are already implemented for the a0.2 build. :)

Jul 5 2012, 12:26pm Anchor

I keep getting a bug where I can no longer attack/dig/mine. I have yet to be able to replicate the bug with any consistency other than the fact that eventually after playing for a while I can no longer get my character to respond to either the left mouse click or the left cntrl. Restarting the game is the only way I have been able to regain the ability to attack/dig/mine. So far I play for 10-15 mins and then must restart the game to continue playing. I also have yet to be able to place the arrow towers I have made left or right clicking them from either my inventory or the hotbar does nothing.

Jul 5 2012, 1:10pm Anchor

Don't click the tank icon, the friends icon and the wrench icon, they cause the left mouse to stop working. Already fixed for v0.2. As for turrets, you just build 4 voxels and drag and drop the turrets on them...

Jul 5 2012, 2:40pm Anchor

Awesome thanks for the workaround and the tips.

Is there a way for me to start over? I have ran so far from my ship and I am completely lost lol.

Jul 5 2012, 4:10pm Anchor

Whenever I start a new game, I just float in the sky and can't move anywhere, or do anything. What am I doing wrong?

Jul 5 2012, 9:04pm Anchor

To start over for now, goto the documents folder of windows and delete the savegame folder.

The floating problem is explained here: Pathea.net

Jul 6 2012, 1:12am Anchor

Just a bug I've run into. not sure if its a permanent thing or not. but it seems whenever i log out and come back in all the arrow towers i have placed down just vanish... just a little curious about that.. other then that really enjoying it :)

also just remembered. whenever you have an item equipped and you log out and its on your toolbar. it go's away..

Edited by: Ck1699

Jul 6 2012, 11:10am Anchor

We'll have most if not all of the saving problems that we know of solved by Av0.2.

Jul 6 2012, 11:10am Anchor

The situation with the arrow towers is even worse for me:

Whenever I run out of their shooting distance they stop working. So I can't pull any mobs to them.

And the local area is not properly saved, even when walking around, so when you come back the towers are gone and the place is full of new mobs.
Landscape is saved though.

When more than two mobs attack you it is impossible to fight or run, because of the knock down, and the respan is not far enough to get away from the group.

I have found six or seven different plants, but not the blue one for the medpack.

The quest to get medical help is a good one, the rest are weird, random and arbitrary.

It seems strange that a chosen colonist has no skills or knowledge whatsoever. maybe move the introductory and tutorial part, to some training room on the ship before the actual game starts. That way it can be easily skipped too. Nothing more irritating for a seasoned player to start a new game and be forced to repeat a tutorial.

And don't make quests like:
You need to dig up 60 dirt right now, if you do that I'll reward your pointless work with the blueprint for an arrow tower. Yes, this is an emergency situation and i have the blueprint, but I wont give it to you until I see you drip some sweat.
Better would be:
We need to secure secure the perimeter, here is the blueprint for an arrow tower, built at least four. Therefor you need 60 wood, and after you are done, I give you some more work.

Jul 6 2012, 11:08pm Anchor

Any news on the Connection Fail Error?, it seem if i reinstall the game i can pass it, but when log in next time i get the error again.

Jul 7 2012, 6:09pm Anchor

Hi,

This game looks really cool and I would love to play it.

My first attempt failed due to the lack of open cl. I would spawn on water unable to move. Now that I have the new drivers and have theoretically fixed it I get a connection fail error when I go to log in.

What have I done wrong?

Thank you,

Rhia

Jul 7 2012, 11:13pm Anchor

Hi Rhia, the server is being tested and fixed right now by the server company, so there might be down time, wait a day or two and it'll be back. Also, the connection issue should be fixed by the next version coming out next weekend.

Aug 3 2012, 4:48pm Anchor

looks like a really great game guys

Jov
Jov
Sep 25 2012, 11:14pm Anchor

I got a CTD (Crash to Desktop) on my first attempt at loading the game, then I reduced the draw distance and it loaded successfully - but I don't know if that's related. I've got a high-end PC so it should have been able to handle it. I would advise making an auto-save after character creation, as I made a nice looking character then lost it to the crash.

After playing for a couple minutes I tried to get a screenshot of a crack in the distant terrain, when the game froze up. Had to shut it down with task manager.

I'm not sure if I was having an issue or not, but I wouldn't describe the graphics as "fantastic" on max settings - on 1080p things seemed a little blurry, especially the ground texture.

Also, just starting out, I'm not sure how to cut down a tree. Punching ala Minecraft didn't seem to work, haha.

Update:

Bugs:

- Body/avatar does take correct shape/appearance until clothes are taken off and put on again
- After quitting to main menu and starting a new game, my new character was naked and in the same location as my last character. As this also means that I do not have a sword to cut down trees, it looks like I'll be needing to start over and create my character a third time :(
-When loading saves it sometimes elevates the character into the air, causing you to float downward.
-When quitting from the in-game menu, the you get a warning that the game hasn't been saved, even if it has.

Spelling grammar/errors:

-When saving it says "Save Successed" - Save "Successful" would be more appropriate.
- When quitting to main menu, the game warns that the player will "loose" all progress. Should be "lose".

PS. Got a tree knocked down, heh.

Edited by: Jov

Sep 26 2012, 2:30am Anchor

Ok, thanks for the report, we'll probably put out another version by this weekend that fixes most of the bugs.

Jov
Jov
Sep 26 2012, 1:45pm Anchor

Another bug:

-When hiring a follower, you can equip or unequip items from them. Then, when you 'release' them, they instantly teleport back to their original spot, with their original inventory restored. This is bad for two reasons: 1) If you equip them with better gear, your items are permanently lost, and 2) You can dupe their items by unequipping their gear, releasing the NPC, then re-hiring them.

It would be super cool if the NPCs walked back to their home-base instead of teleporting, and if they just started following you when hired, rather than teleporting behind you.

Bugs aside, I'm quite impressed with the game so far. :)

Update:

Made a sword! First "3D modelling" I've ever done! :)

Bugs:

-Confirmed. Pressing Prt Scr freezes the game for me.
-Follower portraits sometimes disappear
-The game can enter a state where loading a save while in-game only loads to a view above the landscape; no character or GUI appears, and nothing can be done except for opening up the menu. However, in this state, you cannot load another save, or even quit. However, you can return to the main menu. Despite this, attempting to load ANY save from the main menu results in the same error-state.
-The giant creature doesn't animate correctly during combat. Also, it turns super slowly, so the smart player will try to run around it to attack from behind, but it is still able to instantly incapacitate the player even though there is no visible attack.
-Sometimes the player's arm is invisible while in first-person mode (observed while using a stone sword).

Suggestions:

-Skippable logo at game start-up
-Sprinting? There is a LOT of long-distance running at the beginning of the game.
-Being able to assign your follower NPCs tasks, like mining the immediate area for a certain mineral. While I was at the crater, my two followers stood idly by as I did all the work, mining maybe 100 units of stone/copper/iron/marble/limestone. Not cool, followers!
-Adding a follower icon on the large map (the one that shows up when you press M)
-Showing the remaining time to revive a dead follower when you hover over their portraits or map icons
-I think the way that digging is implemented is really cool, but I think too much earth disappears from a single shovel-action. Although decreasing it would make large-scale digging projects more tedious, I think the change would aid immersion.
-Being able to see the player's full body while in first person. This is more realistic and I LOVE when it's implemented in games. Either way, the first-person arm is too high and it should bob while running.

Edited by: Jov

Nov 17 2012, 1:08pm Anchor

Says no opencl platforms and stop works

Dec 5 2012, 4:02pm Anchor

No linux build?

Dec 5 2012, 9:13pm Anchor
palodequeso wrote:No linux build?

Not at the moment. We will try to add one before beta.

Dec 15 2012, 8:30am Anchor

This annoying display bug makes the game unplayable for me :(
As you can see below the HUD is rendered unrecognizable, while other interface elements including the item builder are displayed just fine. I've tried starting the game with different display settings but that didn't really help the problem - seems like either the LOD is messed up or a filter or the like is overlapping it. (perhaps this is already a known bug)
I was using alpha 0.4 when this bug occurred.

Since the output log also seems to have thrown a few errors I have included it here:
Mediafire.com

My graphics card is a ATI Radeon HD5700 series.

Oh and a suggestion here: I have a very small screen and it sucks if I cannot move the interface elements to reach buttons etc. (like the window at the character creation screen or the mirror screen at the item builder)

Edited by: b5cully

Dec 17 2012, 9:18pm Anchor

Hi Guys, noob here..... downloaded latest version and am stoked. However, i lock up at 65% every time i load the game. have render distance at 256 and choose good for vegetation setting. Got a powerfull system, yep. Anyone know what im doing wrong please? Thanks, Dave.

Dec 19 2012, 8:00am Anchor
b5cully wrote:This annoying display bug makes the game unplayable for me :(
As you can see below the HUD is rendered unrecognizable, while other interface elements including the item builder are displayed just fine. I've tried starting the game with different display settings but that didn't really help the problem - seems like either the LOD is messed up or a filter or the like is overlapping it. (perhaps this is already a known bug)
I was using alpha 0.4 when this bug occurred.

Since the output log also seems to have thrown a few errors I have included it here:
Mediafire.com

My graphics card is a ATI Radeon HD5700 series.

Oh and a suggestion here: I have a very small screen and it sucks if I cannot move the interface elements to reach buttons etc. (like the window at the character creation screen or the mirror screen at the item builder)


This is due to you selecting the fastest or fast quality at the start of the game, Unity then proceeds to down res the textures 4X, then 8X, which is what causes this. We have it fixed for A0.5.

Jan 10 2013, 11:36pm Anchor
zede05 wrote:This is due to you selecting the fastest or fast quality at the start of the game, Unity then proceeds to down res the textures 4X, then 8X, which is what causes this. We have it fixed for A0.5.

Thats what I thought as well, until I've tried running it on the best quality options to figure out. I just tried it again, starting the game with fantastic quality and 1024x768 non-windowed mode, still got the same results. /shrug Will download the latest alpha build once you released it, and report back to you if it's working with this version.

Edited by: b5cully

Feb 25 2013, 5:19pm Anchor

Alright, here's my overly critical feedback:
When I started I had no direction, that's to say that I didn't know what I was supposed to do. I'm pretty sure I punched the sick lady a half dozen times before I realized I needed to right click to talk to her. Then, when I walked around I had no idea you needed to hold down the right mouse button to change orientation, and I pretty much just ran sideways, facing north for quite some time. Then for a starter mission the "base" was much further away than I'd expect it to be. Generally speaking, the crater and big tree were too far as well. Perhaps if the run speed were slightly faster it wouldn't have been an issue, but several times I though the marker was bugged out and I'd never reach the end point. I wasn't aware that I started the game with a knife, in fact I must've killed a half dozen of those monkey looking things by punching them to death before I realized I had an actual weapon. (And yes, that took a while.) Then I ended up on a quest to kill six specific creatures, except I had no way of knowing which creatures they were. Nothing pops up when you mouseover or even click on the creatures. Then mobile combat is kinda tricky because yo have to actually click ON your target. Later on when I had to gather copper and iron I had no way of knowing I needed special tools, since my knife worked to cut down trees I figured it was just a general purpose thing. But after I got the shovel and the pickaxe and started digging around I actually realized that your holes were created where you clicked, so I figured the same would be true of combat. Even still, I wasn't aware of how the reward/quest completion system worked because I didn't receive any notice saying "you have just received 3 med packs" or whatever. I'm as hack and slash as they come, but I thought the first few quests of killing things just to learn to make a torch was a bit odd, I would have preferred a gatherer style quest prior to the hunter versions.

Of course, that's as far as I've gotten so far. After playing for two hours and doubling back a half dozen times because of the distance.

I'll admit that I can be pretty dense at times, but I really did feel lost out there just sorta wandering around most of the time. It wasn't until I ended up killing the Ryan guy and took his pickaxe did I realize how most everything worked. So I really think that it just needs some sort of true "starter" quest so that users become familiar with the controls and how the quest completion/reward thing works.

All in all I'm actually looking forward to coming back and playing some more.

Reply to Thread
click to sign in and post

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.