Combining its own unique take on the real-time roguelike genre, with a nostalgic 16-bit look and feel; Diehard Dungeon is a game that feels both familiar and quite different at the same time, "occupying a curious middle ground between The Legend of Zelda and The Binding of Isaac". [Edge online 2012] Followed by a trusty, treasure collecting companion chest, the player must make their way through the dungeons many randomly-generated rooms and levels. Armed with a sword and a ‘hand cannon’, all manner of nasty dungeon dwellers, bosses and traps will need to be defeated or traversed in order to emerge from the dungeon victorious! To aid them in their quest, the player may be lucky enough to encounter one or more upgrades, or new abilities, scattered throughout the dungeon. A randomly generated dungeon is created every playthrough. Discover the dungeons many secrets and multiple outcomes. Do you have what it takes to survive the dungeon?

Forum Thread
by member
Can't boot game (Crashes) (Games : Diehard Dungeon : Forum : Bugs and Glitches : Can't boot game (Crashes)) Locked
Thread Options
Apr 19 2013 Anchor

As soon and I double click to play in Desura it crashes. Is there any log files that I can view to see what the problem is? I really want to play this.

I hope I posted this in the correct place. I would see this as a bug.


Windows 7 64bit SP1

Edited by: isaacb142004

Apr 20 2013 Anchor

Hi, yes this is the correct place :)

Have you tried reinstalling? Someone else had the same issue that was fixed by reinstalling Desura, as it was causing problems. Do you get an error message or anything popup?

Unfortunately, there's no logging of errors at the moment.

The DRM free standalone version should be available to download either now, or very shortly (waiting on the Desura team to approve). That may completely fix the issue.

Please keep me updated and I'll do whatever I can to get it working for you.

Apr 20 2013 Anchor

I reinstalled it and this is the crash.

I hope this can be fixed soon. Im running this on a SSD if that means anything. Thanks for your help. Can't wait to play.

Apr 20 2013 Anchor

Version 1.31 crashes on play game if left in full screen mode on windows 7 64bit with dual montiors supect the directx fullscreen settings need adjusting in game code.

Game works fine in windowed mode

Apr 21 2013 Anchor

How do I set in windowed mode without oging into the game? Whats the Desura launch command?

Apr 21 2013 Anchor

isaacb142004, could you please tell me what resolution your desktop is?

To force the game to start in windowed mode, open the file C:\ Users\ *yourname*\ Documents\ SavedGames\ DiehardDungeon\ DiehardDungeon_Save\ AllPlayers\ DiehardDungeon_Options in notepad and change the last entry from False to True. Save and then try running the game again.

If the file doesn't exist, then it's a problem with either corrupt files or xna/.net. Please try the possible solutions in the Troubleshooting sticky thread.

Apr 21 2013 Anchor

I am having the same problem here, when I start the game I immediately get an error.
Fortunately I am a programmer so I have this for you: (with that I am also implying I have XNA and .NET working ;) )

Apr 21 2013 Anchor

Im running 2 monitors both running 1920 x 1080 and I disabled 1 of the monitors to see if that was the problem and still a no go. I enabled window mode with the settings you gave me and I keep getting the same thing.

Im using RAMDisk if that has anything to do with it but all my other games work fine (Steam and Desura).

Windows Event Logs:

Thank you so much for spending your time to help me.

Edited by: isaacb142004

Apr 21 2013 Anchor

Don't mention it, I'll do whatever I can to get it working for you.

Ok, I think I know what the problem is. Have either of you removed or disabled Windows Media Player?

You are both encountering the same problem with WMP failing to load/play the starting music. I've never encountered this issue myself, but have done a bit of research and it seems to be a common issue with XNA games, as they require WMP for music playback (yeah it sucks!).

To enable WMP goto: Control Panel -> Programs -> Turn Windows features on or off

Make sure that WMP is enabled and updated.

Apr 21 2013 Anchor

I cant enable it. I get an error.
Is there a way around it, like a compatibility mode? I would like to keep WMP off the computer. Could you make a compatibility mode without requiring WMP?If not I will just play my other games.

I do think that enabling WMP will fix the problem.

Thank you

Edited by: isaacb142004

Apr 22 2013 Anchor

Hi, I'm sorry but unfortunately there's no way around the requirement, except disabling the music altogether. I could patch the game to not play the music at all if the volume is set to 0, which would let you play, but without any sound :(

Apr 22 2013 Anchor

That would be great to have options like that. Thank you so much for going the extra mile just so I can play. Im going to rate a 10 just because youre a great help.

Thank you again.

Apr 22 2013 Anchor

Thankyou! :)

I'll add this into the next patch.

Apr 23 2013 Anchor

Thank you so much! I can play now after the last patch. Very fun so far! :)

Apr 23 2013 Anchor

You're welcome! :)

I'm looking into other methods of music playback, so hopefully you won't have to play without music for too long.

Reply to thread
click to sign in and post

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.