Forum Thread
by member
  Posts  
Stalker CoP Game Crashing (error handler is invoked!) (Forums : Development Banter : Stalker CoP Game Crashing (error handler is invoked!)) Locked
Thread Options
Jan 2 2013, 3:42pm Anchor

I've been modding the gamedata folder, and only the folder. But now after a day I come back to try my modded game - the game crashes with this being said in the error log file in my documents folder:

FATAL ERROR [error]Expression : error handler is invoked![error]Function : invalid_parameter_handler[error]File : D:\prog_repository\sources\trunk\xrCore\xrDebugNew.cpp[error]Line : 815[error]Description : stack trace:

For some reason, it didn't give me a description, so now I can't figure out how to fix it.

You know what, there's something that I might have forgot that I edited and didn't test it. I used a backup gamedata folder from recent editing to replace to other one after I reinstalled the game. Now it works just fine.

May 10 2013, 9:01am Anchor

I created an account to answer you. I had exactly same error.

The case is: your SAVEGAME contains a *SPAWNED* OBJECT that has different qualities than in configuration data. Consider starting new game or loading save BEFORE that object was spawned in the world.

My specific problem was: I wanted to add automode to SVU. I cloned a SVU (svu_s), gave it to nimble list in script as fouth option, edited hell of xml and script files - dialog text and dialog options. Tools like windows grep helped a lot here.

So Nimbled gave this rifle, but regardless if I set "fire_mode" to 1, -1, it still not auto.
The reason was, that one needs class "class = WP_AK74" instead of "WP_SVU" to allow autofire.

After change, there was a lot of dumb crashes with requirement to add a fake grenade launcher, etc. Just see "wpn_vintorez" for reference.
But after that - this error. And no description. I added further stuff, added hud etc - no change. Then I thought about that, reloaded earlier save, respinned Nimble till he gave me my rifle, and voila - it worked now, with autofire etc. And this save game - reloads as well.

So, I also heard that somebody referenced that objects such as map markers etc can TOO cause this error. Just think about as "an object found in save game, that differentiates from description significantly". Hope this helps you.

Reply to Thread
click to sign in and post

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.