Forum Thread
by member
  Posts  
Problem in hiding green points (bones) in general zero hour (Forums : 3D Modeling & Animating : Problem in hiding green points (bones) in general zero hour ) Locked
Thread Options
Apr 9 2013, 2:19pm Anchor

Hello.I have a problem in exporting w3d files:
I saw a helicopter and decided to edit it and set a new texture on it.I opened that w3d file in gmax with w3d importer script and saw some green points and wanted to delete it.I researched about it and understood they are very important.So I did not remove it and finished my work (texturing).I exported my new model in w3d file and put it on generals zero hour but I saw this in game:



I drew a red line around green points

green points in game !!!! I tried to hid it in game But not successful.I cant delete it because it is very important that points be in game (the result is animating and script code in game). I do not know what to do [:(] !! when I deleted that points and then put helicopter in game ,the combat drop didnt work.

so I must have that green points but in the hidden mode in game.

This is my problem:
How to hide green points in game without any problem (such as problem in combat drop that i put a picture from it in The upper line) ?

Please help me :( :( plz plz .

Apr 9 2013, 5:13pm Anchor

Those are bones, but depending on their use I think it's best to call them as helpers or tags.
When being used as bones, you animate parts of your mesh with them.
When being used as helpers\tags, you specify with them the source location from which a special effect will come (smoke, particles, etc.).

According to this tutorial (Derelictstudios.net) you need to do two things:

  • Appropriately name the bones in GMax so the game recognizes them as bones\helpers\tags and is able to display effects from them. You need to reference the INI file you're using for that mesh. If the bones follow the naming convention specified in the INI, the game will recognize these objects as bones and will display effects\animation from the properly.
  • Turn off the Export Geometry in GMax for each bone object, so only their transform (that is, their position\rotation\scale information) is exported. That's all the game needs to know from the bones anyway, where they are and what are their orientation, animation etc.

Edited by: RNavega

Apr 10 2013, 7:31am Anchor
RNavega wrote:Those are bones, but depending on their use I think it's best to call them as helpers or tags.
When being used as bones, you animate parts of your mesh with them.
When being used as helpers\tags, you specify with them the source location from which a special effect will come (smoke, particles, etc.).

According to this tutorial you need to do two things:

  • Appropriately name the bones in GMax so the game recognizes them as bones\helpers\tags and is able to display effects from them. You need to reference the INI file you're using for that mesh. If the bones follow the naming convention specified in the INI, the game will recognize these objects as bones and will display effects\animation from the properly.
  • Turn off the Export Geometry in GMax for each bone object, so only their transform (that is, their position\rotation\scale information) is exported. That's all the game needs to know from the bones anyway, where they are and what are their orientation, animation etc.

Thanks.Thank you very much RNavega. I test it.It worked.
I hid it in game without any problem.
Moddb is the best.
Where is thanks button ?

casf01
casf01 Rigger / tech artist
Apr 11 2013, 10:28pm Anchor

On a side note : check the classof the obj... Is there any modifiers applied on those point? Even what max call an empty modifier( even ifs its just an empty shell) like the attribute eitor can onvert your bone to a geometry in most eporter.... Getting rid of those or fixing the class of the obj will fix the problem for good without having to ply with the export settings

Reply to Thread
click to sign in and post

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.