Post download Report content Third Age - Total War 3.2 Patch
Filename
TATW_3.2_Patch.exe
Category
Patch
Uploader
TW_King_Kong
Date
Size
217.77mb (228,349,212 bytes)
Embed Button
Mirrors
Download now
Description

Patch 3.2 Download. Click on read more to see the full changelog and notes.

Preview
Third Age - Total War 3.2 Patch
Post comment Comments  (100 - 150 of 492)
1malhahaha
1malhahaha

St├╝rtzt es immernoch ab wenn die automatische Sommerzeit aktiv ist?

Reply Good karma Bad karma+2 votes
pacman24
pacman24

third age total war is not a game, its a way of life!!!

Reply Good karma Bad karma+2 votes
anth799
anth799

num num num

Reply Good karma Bad karma+2 votes
jasoncape
jasoncape

Is this fun or what? :D

Reply Good karma Bad karma+1 vote
onikenshin
onikenshin

Do I need both parts or just the 3.2? It says it's a standalone.

Reply Good karma Bad karma+1 vote
Guest
Guest

This comment is currently awaiting admin approval, join now to view.

TheCheezer
TheCheezer

dl does not work for me..

Reply Good karma Bad karma+2 votes
1malhahaha
1malhahaha

what do you think "PATCH" means?

Reply Good karma Bad karma+3 votes
jgoddard5858
jgoddard5858

SO i DOwnloaded 3.0 and the 3.1 patch and when i go to play a battle of any type it loads it up then when the battles starting like I can hear the music and sometimes it will show a second of your men, it exits out an says there was an unspecified error. I had the 1.0 game for like a day but the sound didnt work but i could play battles fine. Anyone know whats wrong with my 3.0

Reply Good karma Bad karma+2 votes
toolbox642
toolbox642

i have the same problem :/

Reply Good karma Bad karma+1 vote
toolbox642
toolbox642

i found the solution :P

delete these 2 files

1. data\descr_geography_new.txt

2. data\descr_geography_new.db

and it should work :) (make a back up just in case)

Reply Good karma Bad karma+3 votes
Guest
Guest

This comment is currently awaiting admin approval, join now to view.

sdthom
sdthom

were can these files be found?

Reply Good karma Bad karma+1 vote
andrewdking1
andrewdking1

in case you haven't found the files yet, just go to: My Computer; Local Disk (C Drive); Program Files; SEGA; Medieval II Total War; mods; Third_Age_3; data. Then just scroll down to the descr_... files and its the only two files starting with "descr_geo". Good luck, and hope it works for you too!

Reply Good karma Bad karma+1 vote
AmazingJOR
AmazingJOR

help me please, i'm to silly i cant find them, and my computer is in spanish because im from mexico but iknow hot to speak english but i simply just dont find it

Reply Good karma Bad karma+1 vote
andrewdking1
andrewdking1

Yes! unbelievable! It did work. I had the same problem and then deleted these files and it worked. I was getting so annoyed trying to change every setting I could to no avail. How on earth (regular earth that is) did you figure that out? I wish I knew things about computers!

Reply Good karma Bad karma+1 vote
soulblade362
soulblade362

hello when i play the fellowship campaign i get an unspecified error when i go to fight the battle with the nazgul in the begging

Reply Good karma Bad karma+1 vote
toolbox642
toolbox642

quick question, does Baron Samedi's submod work for TATW 3.2? or do i have to use 3.1?

If I can only use it for 3.1, about when will it be compatible with 3.2? :P

thanks in advance!

Reply Good karma Bad karma+1 vote
toolbox642
toolbox642

nvm i just read it on twcenter :P

Reply Good karma Bad karma+1 vote
darioana
darioana

I cant start a new third age campaign since i downloaded this patch. how can that be fixed?

Reply Good karma Bad karma+1 vote
therealbeargrylls
therealbeargrylls

can i get this if i downloaded medieval 2: total war gold edition from gamestop, instead of steam? if not can i get a refund from gamestop?

Reply Good karma Bad karma+1 vote
VisioN
VisioN

How am i supposed to play the game without a shortcut on my desktop or a .bat file. Does not start up!!

Reply Good karma Bad karma+1 vote
CappieD
CappieD

exactly someone please help, i have the same problem... got the mod installed, but i have no way to launch it

Reply Good karma Bad karma+1 vote
Huntermm135
Huntermm135

rtyuiop

Reply Good karma Bad karma+1 vote
Arena_Baller
Arena_Baller

say do I need patch 3.1 first?

Reply Good karma Bad karma+1 vote
Zerg8
Zerg8

one question i installed this mod. and i was wandering if im able to install more than 1 mod. for medieval 2 TW?

Reply Good karma Bad karma+1 vote
wiio6
wiio6

i did all the renaming and i cut all the stuff in the ta3 folder and i put it in the tuetonic i started it up with luancher and it showed third age then it crashed plz tell how to fix

Reply Good karma Bad karma+1 vote
flyboy51
flyboy51

try turning off daylight savings mode on your clock. Idk why but it worked for me.

Reply Good karma Bad karma+1 vote
victamagnus
victamagnus

can anyone tell me how to switch the high elves back to the old models, i can figure out how to select them just not how to replace the ones with the same names.

Reply Good karma Bad karma+1 vote
flyboy51
flyboy51

Does anybody know if they are going to make an actual Barad Dur for the campaign map? Right now its just a weird fortress thing. Kinda takes the fun out of whooping on Mordor.

Reply Good karma Bad karma+1 vote
Plex2MeetU
Plex2MeetU

Why won't it download? I click download and it just take me back to the other page?

Reply Good karma Bad karma+1 vote
DarthJokerFett
DarthJokerFett

So, does this patch include the 3.1 patch, or do I need to download both?

Reply Good karma Bad karma+1 vote
Carnistir
Carnistir

I have found a bug maybe it's just with me but i can't do costum battles or in campain real time battles. Can anyone tell me what i have to do so i can play costum battles?

Reply Good karma Bad karma+1 vote
Carnistir
Carnistir

I have this problem with the new patch 3.2 any thoughts?

Reply Good karma Bad karma+1 vote
undeadshadowknight
undeadshadowknight

I had the same problem, all you have to do is Uninstall it, then reinstall it. It worked for me

Reply Good karma Bad karma+1 vote
Carnistir
Carnistir

Do i have to reinstall only patch 3.2 or the whole 3.0 series?

Reply Good karma Bad karma+1 vote
Carnistir
Carnistir

I have uninstalled it and reinstalled it but i still have the same problem i can't play custom battles

Reply Good karma Bad karma+1 vote
undeadshadowknight
undeadshadowknight

do you need 3.1 installed first?

Reply Good karma Bad karma+1 vote
CappieD
CappieD

Guys i have a very stupid problem, i downloaded the mod, but i don't know how to start up the mod, because it doesn't create an icon on my desktop.. what the hell do i do?

Reply Good karma Bad karma+2 votes
Guest
Guest

I have the same stupid problem.
did you install it?
If u solve it tell me

Reply Good karma Bad karma+1 vote
Sciipi
Sciipi

you could go to you mod's folder and rename the one of the folders crusades, Americas, teutonic and the british ilse or something like that, just add a 1 to the end and then rename the folder Third_Age_3 to whatever the folder you renamed was without the 1. start it like you would start the mod and you will be fine

Reply Good karma Bad karma+1 vote
Guest
Guest

This comment is currently awaiting admin approval, join now to view.

Guest
Guest

This comment is currently awaiting admin approval, join now to view.

Malinos
Malinos

I'm getting a strange crash during a battle in my Gondor campaign. I have half a stack near Minas Morgul, and I attacked a small Mordor force standing next to the fortress, which forced the garrison to join the attack ( a tactic I like to use to avoid the AI cheat code that creates a massive garrison force when under siege ).

I start the battle fine, line up my rangers and archer militia up on a high hill, with a few infantry lined up behind and a single cav unit behind them. After awhile the animation gets really choppy, and shortly after attacking the game crashes to desktop with the "unspecified error..." message. This happens whether I send my cav in, or move my archers into range - but it seems to happen when the AI gives orders to attack in return.

- I have read the forums
- I have disabled DST on my computer
- my graphics card works fine, and is using current driver
- I have uninstalled/reinstalled 3.0 and both patches
- This particular crash doesn't happen on normal battle maps, only the scorched earth Mordor map near Minas Morgul

What's going on?

Reply Good karma Bad karma+1 vote
Arimannio
Arimannio

I keep having a problem with the download link ''Page not found''

Reply Good karma Bad karma+1 vote
Guest
Guest

This comment is currently awaiting admin approval, join now to view.

Guest
Guest

This comment is currently awaiting admin approval, join now to view.

Beethoven1
Beethoven1

i says that it cant find the "Kingdom.dex" or somthing what do i do?

Reply Good karma Bad karma+2 votes
raider653
raider653

same problem please someone help

Reply Good karma Bad karma+1 vote
Guest
Guest

This comment is currently awaiting admin approval, join now to view.

Post a comment

You are not logged in, your comment will be anonymous unless you join the community. Or sign in with your social account:

Download
Browse
Downloads
MD5 Hash
13d7123aa9f912e5eccb90921097a849
Share
Related Games